Loss of power PLEASE HELP ME - GSXR.com
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-17-2017, 11:16 AM Thread Starter
Squid
 
GSXR MANOLO's Avatar
 
Join Date: Feb 2017
Posts: 6
Loss of power PLEASE HELP ME

Ok before I completely lose my sanity .... I have a 2007 GSXR 600 with a PC3 and TRE switch installed ...... the pc3 failed on me on the way to panama city and shut the bike down, the battery died and all ... so I just replaced the stator and rectifier and took the pc3 off as well as the TRE switch and I just installed new NGK iv iridium plugs but yet it is still losing power in low rpm in first gear .... can anyone help me resolve this ? Thanks in advance 🤙🏾


Sent from my iPhone using Tapatalk
GSXR MANOLO is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-17-2017, 11:47 AM
Lifetime Premium
 
rv6john's Avatar
 
Join Date: Mar 2013
Location: In the twisties around Hendersonville, NC
Posts: 5,667
This should be in the tech section. I asked the mods to move it.

I don't understand the sequence of events. Are you saying the PC killed the battery?

After changing the R/R and stator did you ever check the charging voltage.

I also don't know what you mean by "but yet it is still losing power in low rpm in first gear". Was it doing this before?

You need to up your communication level a bit.

Quote:
Originally Posted by Chuckster View Post
If you think reading is tricky, how the hell are you going to follow troubleshooting directions?
"Riding well is difficult, riding poorly is easy and painful."
- Nick Ienatsch


"We're all here because we're not all there" - Guy Favron on Gold Rush

K6 750
rv6john is offline  
post #3 of 7 (permalink) Old 05-17-2017, 01:18 PM Thread Starter
Squid
 
GSXR MANOLO's Avatar
 
Join Date: Feb 2017
Posts: 6
Quote:
Originally Posted by rv6john View Post
This should be in the tech section. I asked the mods to move it.



I don't understand the sequence of events. Are you saying the PC killed the battery?



After changing the R/R and stator did you ever check the charging voltage.



I also don't know what you mean by "but yet it is still losing power in low rpm in first gear". Was it doing this before?



You need to up your communication level a bit.


No I wasn't saying that the PC killed the battery.... I was simply just stating the series of events that happened but however that's irrelevant at this point ...... my bike was running perfectly fine with a TRE switch installed and a PC3 .... somehow the PC3 failed and my bike wouldn't start back up after I cut it off and the battery also died in the process trying to get it to start back up .... so I bought a new battery . New stator and rectifier all OEM PARTS .... I took the TRE switch off the bike which is what tricks the bike into believe it is in 5th gear at all times ... and I took the pc3 off the bike .... now the bike will start up and run and sounds solid while idling but if I turn the throttle it lags around 6k rpm .... i just spoke with a friend moments ago and he stated that he thinks it may be out of tune .... what do you take of the current situation ? Thorough enough ?


Sent from my iPhone using Tapatalk
GSXR MANOLO is offline  
 
post #4 of 7 (permalink) Old 05-17-2017, 01:53 PM
Lifetime Premium
 
rv6john's Avatar
 
Join Date: Mar 2013
Location: In the twisties around Hendersonville, NC
Posts: 5,667
I hope you understand that "yet it is still losing power in low rpm in first gear" and "but if I turn the throttle it lags around 6k rpm" are two different symptoms.

If it is actually the latter, I agree with your friend, you probably need another PC and a tune.

Thank you for explaining what a TRE is.

Quote:
Originally Posted by Chuckster View Post
If you think reading is tricky, how the hell are you going to follow troubleshooting directions?
"Riding well is difficult, riding poorly is easy and painful."
- Nick Ienatsch


"We're all here because we're not all there" - Guy Favron on Gold Rush

K6 750
rv6john is offline  
post #5 of 7 (permalink) Old 05-17-2017, 03:12 PM
Racer
 
Racerxxxgsxr1000's Avatar
 
Join Date: Dec 2016
Location: Texas
Posts: 740
The TRE advances timing and removes top speed limit due too as he said ,tell ECM it's in 5th. I did notice it would warm up faster and hit cooling fan much quicker.

.
.
.
.
.
.
"Crazy people don't know they're crazy, but I know I am, so I must not be crazy"
Racerxxxgsxr1000 is offline  
post #6 of 7 (permalink) Old 05-17-2017, 03:24 PM Thread Starter
Squid
 
GSXR MANOLO's Avatar
 
Join Date: Feb 2017
Posts: 6
https://video-atl3-1.xx.fbcdn.net/v/...=591E76D1&dl=1


Sent from my iPhone using Tapatalk
GSXR MANOLO is offline  
post #7 of 7 (permalink) Old 05-17-2017, 03:25 PM Thread Starter
Squid
 
GSXR MANOLO's Avatar
 
Join Date: Feb 2017
Posts: 6
This is a video of the lagging I was referring to , my buddy had just installed the new stator and rectifier and ngk iv iridium spark plugs


Sent from my iPhone using Tapatalk
GSXR MANOLO is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GSXR.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome