'07 GSXR 750 - Help Troubleshooting - GSXR.com
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-26-2008, 01:43 PM Thread Starter
Join Date: Sep 2006
Location: Olympia, WA
Posts: 7
'07 GSXR 750 - Help Troubleshooting

Okay, just installed new motor, wiring harness, PCIII, ingition module, Yoshi full system.

Motor runs fine. Put in gear and takes off fine. When I get to 25-30 mph in first at about 4-4.5K rpm the motor cuts out until speed is lowered and rpm's are lowered. If I quick shift, I can get it to go faster, but again, at about the same rpm it will cut out again.

Obviously some switch or something is not doing it's normal thing so the motor is being told to cut out a certain RPM. Also, the red light on the cluster stays on. The oil icon goes out, but the read light stays on. Again, I'm sure that probably some fault code, but not sure what it is.

Any ideas?

Randy Bailey

PNWRiders Racing Team
Bridgestone Tires
Adrenaline Freaks Track Days
Power Stands Racing
More Power Racing
Race Tech Suspension
Vortex Racing
Motorex USA
redrider2 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-26-2008, 03:53 PM
Pro Racer
Join Date: Dec 2004
Location: Olathe, KS
Posts: 1,835
Do a search on how to pull up the FI light code and how to read it.

sig pics can not be larget than 200 pixels tall and 500 pixels wide.
onedownfiveup is offline  
post #3 of 3 (permalink) Old 05-12-2008, 09:35 PM
Join Date: May 2008
Posts: 4
mine too

My bike is doing the same thing did you find out what the problem is??
gixstar is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the GSXR.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome