electrical problems / GSXR 1000 /03 : GSXR.com Forum : Suzuki GSX-R Forums
 
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   GSXR.com > Tech > Tech and performance chat.

Reply
 
Thread Tools Display Modes
Old 11-17-2008, 02:07 AM   #1
nuno1959
Squid
 
Join Date: Sep 2006
Posts: 2
Default electrical problems / GSXR 1000 /03

hi guys
until recently i was a VERY happy GSXR 1000/K3 owner, bought secondhand with just 5000 km on it - totally sweet !! but a while ago its electrics started playing all sorts of ''dirty tricks'', driving me nuts in the process. first was a problem with the FI which got sorted, then the exhaust valve (it wouldn't open..& the only way my mechanic got to fix it was to make it stay open - i don't know how...) & now i have this peculiar thing going : when i insert & turn the key i get that characteristic display of tach needle going around then back , fuel pump priming noise & such but sometimes such noises go on & on, other times only one of the noises happens( no pump primming noise here...) & just to get me real confused sometimes no noises at all. obviously this results in being abble to start the bike or not, depending. when riding lately i have had the added ''bonus'' of always having my neutral light on plus the side stand not killing the engine when deployed. also in the morning usually there isn't enough juice to start the bike - although it starts imediately going a few feet downhill, after riding it for a few miles it has more than enough juice to start , over & over again, no problems. also on removal of the fairing panels i found out a melted corner on a plug coming out of the rectifier ( big finned lump on the side of the seat ?..) which i insulated by applying a gob of Tech 7 mastique/silicone thingy. after finding this i thoroughly inspected EVERY contact on the electrical system, EVERY wire, fuse - you name it & finished it off by a very liberal spraying of WD40. had some corrosion on some plugs/contacts & got rid of that too.
tried to go riding the next day & same things happened.....all over again !! AAARGH"#&$* !!! just as if nothing had been done....
can anyone please shed some light here please, pretty please ? it's taking all the pleasure i have riding

although i am a reasonably adventurous/methodic/skilled newbie mechanic, when it comes to electrics my knowledge is zilch : i'm lucky to know there's a positive & a negative & that's about it.....
desperate from the south of Portugal....

Last edited by nuno1959; 11-17-2008 at 02:09 AM.
nuno1959 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-17-2008, 02:31 AM   #2
daviditaly
Novice
 
daviditaly's Avatar
 
Join Date: Apr 2008
Location: Maryland
Posts: 49
Default

I had the problem with the FI too, cost me over $1500 to get fixed, are you sure your red cut off switch is always set to on? could it be thats why you cant hear the pump? maybe something is loose..

Also go have your battery checked, mine doesnt start sometimes and when I run with it the bitch starts right up lol might have a dead cell in the battery cuz after riding around for a bit its fine.

Also a good think to always have is a battey tender to charge ur battery all the way back up.
__________________
Check out my R8 post for more sexy pics!
daviditaly is offline   Reply With Quote
Old 11-17-2008, 03:39 PM   #3
gixxerfreek1
Novice
 
gixxerfreek1's Avatar
 
Join Date: Oct 2008
Posts: 27
Default electrical problem

Sounds like your ignition switch to me, there are contacts in the bottom of the switch, there is a cover on the bottom with two security screws so if you can get those out inspect the inside of it make sure it looks good. The screws are a bit hard to get loose but I had the same symtoms and that was my problem.
gixxerfreek1 is offline   Reply With Quote
Old 11-17-2008, 03:56 PM   #4
jonblaze
Rider
 
jonblaze's Avatar
 
Join Date: Feb 2008
Location: Winchester VA
Posts: 327
Default

If you look at your repair manual (bible) , it will tell you how to troubleshoot each device. You need a cheap multimeter. You'll be doing a lot of ohm tests. Ohm is the unit of measurement to test resistance. Your ECU communicates with all these devices. It could be going nuts or bad. A bad battery also screws all kinds of shit up. That melted rectifier is not a good sign. It can screw up ypur battery, overcharge your system and screw all kinds of stuff up too. I'd start with the most problematic and consisitent problems first. Good luck
__________________
WHY ARE WE DYING TO LIVE
IF WE'RE JUST LIVING TO DIE
jonblaze is offline   Reply With Quote
Old 11-19-2008, 04:06 PM   #5
nuno1959
Squid
 
Join Date: Sep 2006
Posts: 2
Default thanks...

well guys , thanks for your help. it sure seems like i'm going to have real fun this week-end.
i think i'll start with the batery & will ''move up'' till the ignition lock, inspecting each & every connector, bit of wire , etc...
today the latest was going at around 100mph in this lovely long bend to the right, the ignition cut out engine power only to kick in again a few meters further !! needless to say i returned home at a VERY sedate pace . anyway thanks again, have a good week-end & as we say here in Portugal : boas curvas !
Nuno
nuno1959 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:54 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2007 2008 GSXR.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum