Voltage question - GSXR.com
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-16-2019, 06:10 AM Thread Starter
Squid
 
Join Date: Jun 2019
Posts: 12
Voltage question

Replaced battery, r/r, and stator. Went with Rick's instead of oem. Getting 14.3 volts at idle but not rising when revved. Manual says 14-15.5v at 5k with hi beams on. Is this ok? I know it'll charge the battery but I've been having so many problems with the charging system, I need to make sure this will do.
Mr.Crisco is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-16-2019, 06:20 AM
Lifetime Premium
 
rv6john's Avatar
 
Join Date: Mar 2013
Location: In the twisties around Hendersonville, NC
Posts: 7,958
14.3 is what I see on most bikes and if anything, it seems to go down a tiny bit as I rev the bikes.

You are good.

Quote:
Originally Posted by Chuckster View Post
If you think reading is tricky, how the hell are you going to follow troubleshooting directions?
"Riding well is difficult, riding poorly is easy and painful."
- Nick Ienatsch


"We're all here because we're not all there" - Guy Favron on Gold Rush

K6 750
rv6john is offline  
post #3 of 3 (permalink) Old 08-16-2019, 07:16 AM Thread Starter
Squid
 
Join Date: Jun 2019
Posts: 12
Awesome thank you. Hopefully my charging issue are gone!
Mr.Crisco is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GSXR.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome