Loosing engine oil 750k1 - GSXR.com
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-28-2019, 05:18 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 5
Loosing engine oil 750k1

Is it common on k1 750 loosing quite a bit oil after every few hundred miles, when bike in the garage do not see any evidence of oil leak. Any Help would be appreciated
sergio101ster is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-28-2019, 05:37 AM
Lifetime Premium
 
Winchester Boy's Avatar
 
Join Date: Sep 2013
Location: Winchester Ky
Posts: 7,913
Garage
No that's not normal.
Is there oil on the air filter or in the air box?

I am a ward of the state.
Winchester Boy is offline  
post #3 of 7 (permalink) Old 07-28-2019, 06:11 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 5
Have not checked to be honest, will do.
If is got oil in the airbox/filter, what causing it?
Thanks
sergio101ster is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 07-28-2019, 06:18 AM
Lifetime Premium
 
Winchester Boy's Avatar
 
Join Date: Sep 2013
Location: Winchester Ky
Posts: 7,913
Garage
Quote:
Originally Posted by sergio101ster View Post
Have not checked to be honest, will do.
If is got oil in the airbox/filter, what causing it?
Thanks
It would be sucking oil from the crankcase through the intake.
John or one of the others can speak about it better than me.
You should also pull the spark plugs.

I am a ward of the state.
Winchester Boy is offline  
post #5 of 7 (permalink) Old 07-28-2019, 12:54 PM
Lifetime Premium
 
rv6john's Avatar
 
Join Date: Mar 2013
Location: In the twisties around Hendersonville, NC
Posts: 7,958
First, are you sure you are not overfilling the oil? With the bike leveled, 1/2-3/4 in the window is fine.

The oil is either leaking out, which you say it isn't, or the engine is burning it. Is it making blue smoke?

It could be forced into the coolant system but you would have some serious other symptoms by now.

Quote:
Originally Posted by Chuckster View Post
If you think reading is tricky, how the hell are you going to follow troubleshooting directions?
"Riding well is difficult, riding poorly is easy and painful."
- Nick Ienatsch


"We're all here because we're not all there" - Guy Favron on Gold Rush

K6 750
rv6john is offline  
post #6 of 7 (permalink) Old 07-29-2019, 11:25 PM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 5
Have not seen any blue smoke.
And oil level was always between min and max level when I filled it up, got my garage ( they did forks on it) after I did oil change on it and they said ohh your oil level was low so we filled it up( could not see through the oil level “window”) so I drained a bit out...
sergio101ster is offline  
post #7 of 7 (permalink) Old 07-30-2019, 05:00 AM
Rider
 
PaulPhilly's Avatar
 
Join Date: Jul 2018
Posts: 409
Check your coolant, check your spark plugs. The oils going somewhere . How fast does it disappear ? Are you checking the oil level at around the same engine temp? You could get a diffrent reading if you check when the engines hot and if you check when it’s cold. Also my 750 would smoke sometimes at first start up on the day once it warmed up it was fine. I would check the oil often but it only needed once a month less than 1/2 quart it did not bother me I would just check the level more often.
PaulPhilly is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GSXR.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome