Help! - GSXR.com
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-23-2019, 08:50 PM Thread Starter
Squid
 
Lovetoride's Avatar
 
Join Date: Jul 2019
Posts: 7
Help!

2002 GSXR 600 charging issue.Brand new OEM Stator and rectifier.Wires get extremely hot once I start the bike.This seems to be a common issue.Any advice?
Lovetoride is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-24-2019, 12:05 PM
Rider
 
PaulPhilly's Avatar
 
Join Date: Jul 2018
Posts: 499
Check out the plug coming off the stator that plugs into the harness of the bike a lot of times they melt and could cause a poor connection.
PaulPhilly is offline  
post #3 of 6 (permalink) Old 07-24-2019, 01:05 PM Thread Starter
Squid
 
Lovetoride's Avatar
 
Join Date: Jul 2019
Posts: 7
It was melted, I'm currently replacing wires, soldering the connections instead of using the snap in connectors
Lovetoride is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-24-2019, 07:45 PM Thread Starter
Squid
 
Lovetoride's Avatar
 
Join Date: Jul 2019
Posts: 7
After replacing some of the melted wire, using the new connectors instead of the Molex, replacing the stator and the rectifier it's now charging at 14.7 at idle and 14.2 at 5000 RPM' S.Any thoughts?
Lovetoride is offline  
post #5 of 6 (permalink) Old 07-25-2019, 08:30 AM
Lifetime Premium
 
rv6john's Avatar
 
Join Date: Mar 2013
Location: In the twisties around Hendersonville, NC
Posts: 8,083
Quote:
Originally Posted by Lovetoride View Post
After replacing some of the melted wire, using the new connectors instead of the Molex, replacing the stator and the rectifier it's now charging at 14.7 at idle and 14.2 at 5000 RPM' S.Any thoughts?
Those are normal readings, sounds like you got it fixed.

Hopefully, you installed quality products and not Chinese crap and you used loctite on the stator bolts.

Quote:
Originally Posted by Chuckster View Post
If you think reading is tricky, how the hell are you going to follow troubleshooting directions?
"Riding well is difficult, riding poorly is easy and painful."
- Nick Ienatsch


"We're all here because we're not all there" - Guy Favron on Gold Rush

K6 750
rv6john is offline  
post #6 of 6 (permalink) Old 07-25-2019, 11:12 AM Thread Starter
Squid
 
Lovetoride's Avatar
 
Join Date: Jul 2019
Posts: 7
I bought OEM parts from the "stealer"ship and I torqued the stator bolts but I did not use loctite.Fingers crossed
Lovetoride is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GSXR.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome