Suzuki GSXR Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Hey guys, i dont hear my fuel pump priming. When I turn the key and flip the switch, theres a sound that comes on and shuts off. it sounds like it didnt complete whatever its suppose to do. I unplugged the fuel pump connector and it does the same thing. Can anyone help me?
 

·
Premium Member
Joined
·
8,554 Posts
More info.

What is it doing and not doing?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3 (Edited)
More info.

What is it doing and not doing?
can i send you a mpeg file? you can see my dash and the little sound. its 11 secs long. Thats all its doing. When i turn the key, i see the rpm go up as usual, then the noise comes on and shuts off and i dont hear the fuel pump priming. all the lights turn on with no flickering.
 

·
Premium Member
Joined
·
1,854 Posts
I'd lift the tank and pull fuel line, put hose on the fuel pump into a cup and turn on key, see if the fuel is coming out, feel pump bottom see if its trying to come on etc.... might have a bad pump, you can check voltage at the pump also.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #5
I'd lift the tank and pull fuel line, put hose on the fuel pump into a cup and turn on key, see if the fuel is coming out, feel pump bottom see if its trying to come on etc.... might have a bad pump, you can check voltage at the pump also.
thank you will do that now.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
so i took off the tank and the pump to make sure everything was connected tight. just for the sake of it, i turn the key and hit the switch and its still making the sound but stopping short of completing what its suppose to do. Could it be something else? im going to get a voltmeter tomorrow and what should i be checking on the pump and where? also, it looks like the pump is not getting a signal when it was connected. Where should i be checking? thanks for the help guys.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
i found what the incomplete sound is and its the actuator. Thats the sound i hear not completing its course. Can anyone tell me if the actuator will cause this issue and what the actuator does barney style? thanks
 

·
Premium Member
Joined
·
8,554 Posts
Is "CHEC" or "FI" showing in the temp window?

Have you checked the fuses?

Did this just start doing this or have you been working on it?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #9
Is "CHEC" or "FI" showing in the temp window?

Have you checked the fuses?

Did this just start doing this or have you been working on it?

There is a chec light when i turn the key but the buzzing sound cuts off. I've checked the fuses where the healight and the fuel fuses are. Are there more fuses besides the starter relay i should be checking? This just started to happen. I went on a ride last week with no probs.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #10
I took off my air box and put the switch to off and manually rotate the secondary throttle body to closed. I put the switch to on and it buzzes longer than it did but doesnt close. I think thats the issue. What do i need to do for the throttle to close?
 

·
Premium Member
Joined
·
8,554 Posts
I'm lost.

I still don't know what the problems is as you've pin balled between the fuel pump not priming to the secondaries.

Are you sure the battery is not dead? You never did say if the starter was working or not.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #12
I'm lost.

I still don't know what the problems is as you've pin balled between the fuel pump not priming to the secondaries.

Are you sure the battery is not dead? You never did say if the starter was working or not.
It cranks over with no issues, its the secondary throttle body where it doesnt cycle through when i turn the key. Im guessing when the buzzing sounds the throttle body closes and opens? but when i turn the key all it does is nothing when i look at the throttle body.
 

·
Premium Member
Joined
·
8,554 Posts
"cranks over with no issues" What does that mean?

Does it start and run?

So your only problem is you think the secondaries are buzzing?
 

·
Registered
Joined
·
1,808 Posts
The secondaries are supposed to stay open when you turn the key on. They'll shut after it's been running for a few seconds. If you're not getting C28 or C29 codes, the secondaries are not your issue.
 
1 - 15 of 15 Posts
Top