Suzuki GSXR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I recently purchased a gsxr (came from a zx6r) and the speedo read zero (I was told it was the speedo sensor. I pulled the sprocket cover and found that the speed sensor rotor was sheared off. My question is has anyone else seen this before?
 

Attachments

·
Super Moderator
Joined
·
8,740 Posts
Welcome.

Not uncommon, it is a brittle pot metal like piece. My guess is the bolt holding it might have been over tightened in the past.

Just buy a new one and replace it.
 
  • Like
Reactions: Racerxxxgsxr1000

·
Registered
Joined
·
952 Posts
I know when taking mine off it was a PITA (pain In the ass) but never seen that before
good thing you checked. Maybe previous owner did it who knows. are your sprockets ok and your rear tire lined up.
can't answer issue but suggest looking at these. I have an 07 750 and I heard something about
the speed clusters having issues. mine works and don't work gear shows and don't show
replaced as much as I could but happens once and awhile
 

·
Super Moderator
Joined
·
8,740 Posts
I have an 07 750 and I heard something about
the speed clusters having issues. mine works and don't work gear shows and don't show
replaced as much as I could but happens once and awhile
There have been few issues posted regarding the cluster. Your issue with the gear position being erratic is not the cluster but the gear position sensor (GPS). And they do get erratic. Some have tried cleaning them, but it is best to replace it.
 
1 - 5 of 5 Posts
Top