Suzuki GSXR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
Hey community, 08 liter bike. I tried finding some post but fell asleep going through all of them. There supposed to be a detailed one I read about believe the title was El Toro but could not find either. Any way my question is on a manual CCT . I went to install one when checking my valve clearance and when I removed the OEM auto adjust one I saw the brass oil pressure port that runs through the auto adjuster. So I pulled it out and installed the manual one. The directions I was told to go by does not say what to do with this. If you have done this before than you know what happened next. Started her up and coated a few things with oil. I realize it sticks out about 3/16 past the head surface. Can I cut that down and JB weld the small hole in the brass fitting and re install it back into the oil port. Or is there another way I should go to do it right. I don't like to Mickey Mouse anything especially on a critical area like the CCT. Any help on the right way to do this would be awesome. Hey thanks in advance guys and girls. Hope to hear some experienced replies. Rubber side down.
 

·
Registered
Joined
·
5,220 Posts
Hi there. I've done the MCCT install on one of my K5 1000's years ago.
It was an APE, or an APE knockoff. Anyways, it had this little black plastic cap that I put in the hole in the block.
It has never leaked one drop since then.
Did you have any plugs like that that came with the MCCT?

HTH
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #3 ·
Hey thanks for your response. No it didn't come with any plugs of any kind. Mine is a ape knock off as well. Got it on ebay. Ad said comes with complete install directions. Nope no instructions. So I notified them and told them they sent me a link to some instructions but there was nothing mentioned at all on that oil port. Do you happen to remember what side plug you used. Thanks for the info.
 

·
Registered
Joined
·
5,220 Posts
Hey thanks for your response. No it didn't come with any plugs of any kind. Mine is a ape knock off as well. Got it on ebay. Ad said comes with complete install directions. Nope no instructions. So I notified them and told them they sent me a link to some instructions but there was nothing mentioned at all on that oil port. Do you happen to remember what side plug you used. Thanks for the info.
It's been a few years since I did mine on my K5 Liter. Should be similar.
IIRC- in the package was this little plastic cap looking thing.
IIRC- I may have removed whatever is in that oil port, put the cap in, and tightened it down.
I do remember I did mine w/o taking off the valve cover on top of the engine. A year two later I had it off to check my valve adjustments. Everything seemed fine. I think I've tightened it slightly once or twice since installing it.

It seems to me if the gasket and plate cover the hole for the oil port, it shouldn't leak anyways?

HTH
 
1 - 4 of 4 Posts
Top