Suzuki GSXR Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I got a 11 gsxr 600 and I low sided the bike last weekend and destroyed the original ignition switch , then I bought one off a guy that had a 2011 gsxr 1000

my question is , are the switches interchangeable as far as the resistor inside the ignition because I plugged up the new ignition and the dash comes on but no fire and the fuel pump dosent prime

really need help please I’m stuck on what to check next
 

·
Mod of the North
Joined
·
29,973 Posts
Which side did you go down on? I am questioning a safety switch somewhere. Clutch, side stand, TOS. Pics of the damage may be helpful.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Went down on the right side at maybe 60 mph but the clutch safety switch is plugged in and good from what I can tell and the side stand switch has been bypassed and not sure if the tos is good or not

also I will post pics shortly
 

·
Administrator
Joined
·
11,696 Posts
Welcome to the forum.

What do you mean by "no fire"? Is the starter turning over the engine or not?

Is "CHEC" showing in the temp window?

To answer your original question, yes both bikes use the same p/n 37100-41G11 switch/lock assembly. There is no specific resistor between bikes.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Nothing showing on the dash but I’m not getting a gear selection or temp reading when I turn the key on and also as soon as I turn my key on the fan comes on ?? And the engine will turn over all day long but won’t start
 

·
Administrator
Joined
·
11,696 Posts
Just went back and looked and CHEC is showing on the dash but no fi light and I don’t have a gear indicator or a temp reading
90% of the time this is because there is no power to the ECM.

You need to be forthcoming with data to get a better answer than that.
 

·
Administrator
Joined
·
11,696 Posts
What would cause no power to the ecm
Lots of things.

Sorry, but you don't provide any information and I'm not good at 50 questions.

Describing in detail exactly what the bike is doing and not doing is a start.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Well for starters I laid the bike down and broke the ignition and after the wreck the only left of the ignition was the copper plugs that are inside the ignition, I took them and kinda held them all together till the dash came one and the bike fired up and then I decided to strip the wires down and splice all of them together after that the bike would turn over but the fuel pump wouldn’t prime , so I decided to get a new ignition and found one from a 2011 gsxr 1000 and put it on the bike and now the dash will come on and the bike will turn over but it won’t start also the fuel pump dosent prime ( also one more thing when I stripped the wires to the ignition I dropped them on the tank bolt and it sparked and blew the 30A starter relay fuse ) and the fuse got replaced , but now I don’t have a gear indicator or a temp reading and as soon as I turn the key the fan comes on

I’m not sure if the data your looking for is like the resistance from the wiring harness or voltages because I don’t have a volt meter to do that and I’m terrible with wiring
 

·
Administrator
Joined
·
11,696 Posts
That helps. Have you checked the other ignition and fuel fuses? Either with a meter or installing a known good fuse?

Do you have a friend with a meter or test light and some electrical knowledge?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
Yes all fuses are good but the other ignition is busted up bad so I don’t think I could re use it plus I’ve already stripped the wires and all the copper plugs in the bottom of the old ignition are gone now along with the resistor too and also I have replaced all the fuses in the small fuse box and the starter relay fuses and idk if there are any other fuses anywhere
 

·
Administrator
Joined
·
11,696 Posts
So I'm getting confused again. You bought another ignition switch then chopped up the wires?

My guess is you have something wired wrong but really don't know what you've done.

I'll ask again, do you have a friend with a meter or test light and some electrical knowledge?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
Oh sorry for the misunderstanding but the new ignition is good but the original is busted and no sorry it’s only me trying to figure this out lol but the new one from the 2011 gsxr 1000 is not working .
 
1 - 14 of 14 Posts
Top