Suzuki GSXR Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I did the dealer mode on my bike and it comes up with -30 code
looked it up and it is the secondary throttle control. i looked fro the
module but i dont have one. in the service manual show it near the RECTIFIER but i dont have anything there. i dont even have the connector for the module. Does anyone one know where its at.
 

·
Registered
Joined
·
612 Posts
Are you looking at electrical schematics or actual pictures of where the manual shows its location? Schematic are just for connections between items representation with components and their parts grouped together.

You also have to remember that an error for a part could also be a connection related to that part is defective and not the part is defective.

Do a parts look up at an online store like Ron Ayers whick will show the location of the parts.

http://fiche.ronayers.com/Index.cfm/Module/Main/TypeID/26/Type/Motorcycle/MakeID/2/Make/Suzuki/YearID/43/Year/2002/ModelID/6834/Model/GSX-R600

http://fiche.ronayers.com/Index.cfm/Module/Main/TypeID/26/Type/Motorcycle/MakeID/2/Make/Suzuki/YearID/43/Year/2002/ModelID/6834/Model/GSX-R600/GroupID/291611/Group/ELECTRICAL

Second link showing item 9 as the FI control. Some of the parts shown are probably up under the seat area behind the battery like the k6 1000. Again a connection or fuse could be disrupted for the error to show.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #4 ·
i have the factory service manual. i lokked up C30 and said it the seconda throttle control module. i cant find the harness that gos tot it or the module it self. took the tail off my bike and nothing.
 

·
Registered
Joined
·
1,621 Posts
Your right, the manual is incorrect as far as I can tell. If I had to guess as to it's location, i'd say it's either within the stva on the side of the tb's or built into the ecu?

It's funny because I also have a k2 600 and while i've never popped that code I have had the rear cowl off numorous times and noticed that it's just not there.:headscrat

Now the really weird thing about all this is that I have a k1 engine in my k2 frame but I kept the k2 tb's, harness, ecu and all the sensors. I know that when i've swapped the two ecu's the k1will start my bike but immediately pops like 10 codes.

The k1 engine i got came with a harness, ecu, sensors, tb's, etc. I noticed on the k1's harness that the STCU is on there right where it's pictured in the manual.

I know the 00-03 gen 750's made a change in the way their secondary throttle system works in between the 00-01 model year, maybe some of that technology trickled down to the 600's and was never updated in the manuals:hmmm:

Or, suzuki just found somewhere else to mount it and we just can't find it:lol:
 

·
Registered
Joined
·
27 Posts
im not sure if this will help. Ive had fi problems with my k3 600 and i have gone through and tested every sensor which has lead me to belive my ecm is bad, just waiting for a new one to test it. Anyways when i bought the bike the previous owner gave me a sensor/computer made by mikuni 32910-39f00. it plugs into the stock harness on the left side behind rear tail. right next to the dealer mode plug. I took this part to the dealer and.... It is a throttle body control unit only some models have it depending on wheather it is canadian or made in california. these models dont have it due to emission
 

Attachments

·
Registered
Joined
·
1 Posts
stva 2002 gsxr1000

I recently got the code c28 and the bike is running. But their is serious popping in the exhaust. Is this due to the stva? This is my first post here and am looking for some direction. Thank you
 

·
Premium Member
Joined
·
14,135 Posts
Youll likely get some answers but this thread is from 09 homie, so dont expect too much more then some heckling from the peanut gallery. STVA and C28 have been widely discussed here tho so def check out the search button.
 
1 - 8 of 8 Posts
Top