Suzuki GSXR Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Well i have read lots about this problem with many different bikes, Problem is i have not found any of these people have found a cure for this...
When you give it a little snap on the throttle the bike is ok for a bit then all the sudden starts to act up and stall mostly if you back off the throttle. or when clutching and then it runs like junk spitting and backfiring..
I have a Hindle slip on and a K&n air filter installed, I have raised the idle like it says in some post and this does nothing but idle higher ( before or after this problem occurs). For the most part if you are gentle on it and never drive the slightest bit hard it happens less frequent.
If you do any driving (besides driving like miss daisy) this problem will eventually happen.


Can someone give me a cure for this????
 

·
Premium Member
Joined
·
9,267 Posts
Well i have read lots about this problem with many different bikes, Problem is i have not found any of these people have found a cure for this...
When you give it a little snap on the throttle the bike is ok for a bit then all the sudden starts to act up and stall mostly if you back off the throttle. or when clutching and then it runs like junk spitting and backfiring..
I have a Hindle slip on and a K&n air filter installed, I have raised the idle like it says in some post and this does nothing but idle higher ( before or after this problem occurs). For the most part if you are gentle on it and never drive the slightest bit hard it happens less frequent.
If you do any driving (besides driving like miss daisy) this problem will eventually happen.


Can someone give me a cure for this????
Your slip on won't affect that, but your K&N air filter is likely make your bike running too lean in the acceleration regime. The cure is to get a Power Commander, or other aftermarket ECU tuning module and have it tuned on a dynamometer.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
ok well i do know the bike was ran on the machine and no codes came up. In all my reading this seems to be a very common problem with a slip on and a k&n air filter on many gsxr's of all sizes so i guess i will go order a new air filter for the bike and swap it out and try that first
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
done a little research and well i have a k&n air filter yes and a hindle pipe yes as for running lean ? hell no lmao it is running rich ! like flames out the exhaust every once in a while and ya well the exhaust pipe is so black inside and the plugs are black as well when i pull them out ... so will a power commander fix this issue if so i will buy one like today cause i can't take the bike doing this anymore i feel retarded when it does it on the road infront of people
 

·
Registered
Joined
·
448 Posts
even the map on the power comander will be set to run a little rich. the best thing to do is get the pc and then have a professional dyno-tune your bike
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
thanks that is what the plan is now cause i don't want this thing blowing up before i get to even use it for one season lol ..... guess i'll be making a trip down to toronto area soon then
 

·
Registered
Joined
·
448 Posts
good deal. mine will be getting tuned this sat at 9 am
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top