Suzuki GSXR Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1 (Edited)
I need some help in diagnosing the actuator. When i turn the key and hit the switch to on, the butterfly opens but doesnt complete its cycle and stays open and stops there. Do i just need to replace the actuator or are there other things i should be looking at as well? If it is bad and nothing can be done, do i have to replace to whole secondary throttle with the svta or just the svta? any help is welcomed. Thanks.
 

·
Registered
Joined
·
1,808 Posts
When you turn the key on, it's supposed to move to the fully open position and stay there. What kind of problems are you having?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
When you turn the key on, it's supposed to move to the fully open position and stay there. What kind of problems are you having?
Before i used to hear a longer buzzing sound and then hear my fuel pump prime. But since this issue, the buzzing sound is short and i dont hear my fuel pump prime. Can the svta issue not cause the fuel pump to not prime is or is pure coincidence? when i look at the throttle valve and put the switch to run, i see the throttle already opened, a quick buzz, the throttle jitters and stays in the same positiion and thats it.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #4
Can you tell me the cycle of the Secondary throttle valves when you the run switch? currently, mine is open and closes about quarter of the way and opens back up half way and wiggles for a few secs and stays at the halfway point.
 

·
Registered
Joined
·
1,808 Posts
Start with them fully closed. That's the normal position when you're done riding and the bike is idling. Then tell me what happens. Did you put it in dealer mode? Are you getting a C28 or C29 code?
 

·
Registered
Joined
·
542 Posts
Be paitent take ur time listen to chuckster I had to do mine 3xs on my 750 before I got it correct. But u will get it rite if u take ur time.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
Start with them fully closed. That's the normal position when you're done riding and the bike is idling. Then tell me what happens. Did you put it in dealer mode? Are you getting a C28 or C29 code?
when this issue started, there were no error codes. the actuator didnt cycle through. It just stayed opened and flickered for a few secs at the open and stopped. if i do fix the issue, how do i know if the secondary throttle is performing as usual. So its started closed, then opens, then what next?
 

·
Registered
Joined
·
542 Posts
You tube has many vids on this , it’s a great way to find a visual of wat is supposed to happen. I got a ton of info from this site but I had to see it for my self to get it rite you tube is the answer
 

·
Registered
Joined
·
66 Posts
Discussion Starter #9
You tube has many vids on this , it’s a great way to find a visual of wat is supposed to happen. I got a ton of info from this site but I had to see it for my self to get it rite you tube is the answer
Yeah i've seen a whole bunch on youtube, but they're differerent models/year and they usually show when they have an issue as well. I need to see an 07 600 in working mode.
 
1 - 12 of 12 Posts
Top