Suzuki GSXR Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
So my k7 won’t idle/Crank I have no code. When I put it in dealer mode I get c00 which means no code so I’m lost. Any help!!!!
 

·
Registered
Joined
·
332 Posts
What happens when you hit the start button? Does the fuel pump prime when you turn the ignition on?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Yes the fuel pump primes when I hit the start button it just turns over and tries to crank. Sometimes it will and rpms jumps around even while holding the throttle but eventually turns itself off
 

·
Registered
Joined
·
2,110 Posts
Any other work to the bike? Have you removed the airbox? Have the cams out? Sounds somewhat like a vacuum leak so I would recommend checking the IAP hoses, especially if you had the airbox off.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Yes the air box has been off. The throttle body has been off and the rectifier has been replaced do to plug melting between the rectifier and stator
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Yes actually it stopped running when the stator/rectifier plug burnt up so I straight wired it.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #10
So good new my bike started but didn’t last long. It’s a plug on the side of the throttle body that hangs on like a rail. When I unplug it the bike runs and idle but RPMs aren’t over 6k. When I plug the mystery plug back in the bike shuts off. The plug I’m referring to leads into the back of the throttle body underneath the fuel rail. Is there anything I’m missing
 

·
Registered
Joined
·
1 Posts
2 resisters in the ignition cylinder if they dont line up the fuel pump will not come on fix your wiring then turn your key to the on posititon ,i just lost my key and thought i could bypass it , you can power it up but the pump wont come on its in the ignitionn!
 

·
Super Moderator
Joined
·
9,008 Posts
2 resisters in the ignition cylinder if they dont line up the fuel pump will not come on fix your wiring then turn your key to the on posititon ,i just lost my key and thought i could bypass it , you can power it up but the pump wont come on its in the ignitionn!
You are correct but if it was the ignition/wiring, it would show a C42 fault code. He said he has no codes.
 

·
Registered
Joined
·
1,109 Posts
Sounds to me (and this is really just a guess) like you have the TPS set wrong. I think you mentioned that you took it off?
 
1 - 16 of 16 Posts
Top