Suzuki GSXR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Please help! I have tried everything I can think off with my bike. The bike is not pumping fuel and I am getting a c29 dealer code for the stps. I have replaced the fuel pump, fuses wiring harness and checked all connections. I have take the hose out to see if pump will pump but it won't even start. The throttle body opens up when I turn the bike on then shuts and clicks a few times.. Bike will run if I use ether in the air filter. Any help I would really appreciate it.
 

·
Registered
Joined
·
80 Posts
Is the fuel pump kicking on? and have you checked your fuel rail and all the lines to make sure there isnt nothing clogging the lines?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Ya I checked everything but the pump won't kick on at all, after the throttle body valves open then close the valves tick a few times then that's all..the bike will turn over and run on ether
 

·
Registered
Joined
·
330 Posts
Ya I checked everything but the pump won't kick on at all, after the throttle body valves open then close the valves tick a few times then that's all..the bike will turn over and run on ether
Nothing a wiring diagram, multimeter and some time won't fix. Best bet is to start tracing wires, checking continuity and grounds.
 

·
Registered
Joined
·
22 Posts
Please help! I have tried everything I can think off with my bike. The bike is not pumping fuel and I am getting a c29 dealer code for the stps. I have replaced the fuel pump, fuses wiring harness and checked all connections. I have take the hose out to see if pump will pump but it won't even start. The throttle body opens up when I turn the bike on then shuts and clicks a few times.. Bike will run if I use ether in the air filter. Any help I would really appreciate it.
Whats up bruh, did you ever figure it out cause Im having the same exact problem with a 2007 gsxr 750? :headscrat
 

·
Super Moderator
Joined
·
9,672 Posts
Having this very same issue,what was your outcome before I take this machine to the dealer..
Welcome, this is a 10 year old thread.

Also, if you did not replace all the items as the OP, you probably don't have the "very same issue".

Best to start your own thread and describe exactly what your bike is doing, not doing along with any history and work you've done.
 
1 - 7 of 7 Posts
Top