Suzuki GSXR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey guys, so I switched out the fuel injectors, fuel pump, and spark plugs on my 2012 GSXR 1000 that I got with 723 miles back in 10/30/21 and now I’ve added a few hundred miles since then but same issues. I thought that doing all these things it would get my bike running but instead it started to throw out a lot of white/blue smoke and she doesn’t want to stay on unless I’m holding the throttle. Anyone ever had these same issues or know how to solve this?
 

·
Super Moderator
Joined
·
10,476 Posts
I don't recall your previous post, but it sounds like you should evaluate the mechanical condition of the engine before going any farther. Compression and leak down tests.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I don't recall your previous post, but it sounds like you should evaluate the mechanical condition of the engine before going any farther. Compression and leak down tests.
I also forgot to add, the injectors I ordered are from Schnitz Racing and they’re 625cc. I don’t know what the stock CC’s are on the original fuel injectors so maybe this might also be the cause for it to not run right? But since it’s white/blue smoke that’s usually related to oil. Which doesn’t add up.
 

·
Super Moderator
1995 GSX-R 750
Joined
·
1,698 Posts
I don't know what the flow rate is on the stock injectors, but if you drastically change the flow rate, you will most definitely need to have the ECU tuned for it. It sounds to me like you are pushing WAY to much fuel into it. I would also bet that there is a lot of gas in the oil now as well. If it were mine, at this point, I would stop running it, change the oil, and take it directly to a tuner. (On a trailer)

I would not rule out Johns suggestion though. Tests need to be done before running it any more.
 
1 - 4 of 4 Posts
Top