Suzuki GSXR Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
I just bought a 98 750 SRAD, so im pretty knew to this but i gotta couple of questions.

First, my battery seems to keep dying on me, it was working fine the first couple days but now it doesn’t seem to work. Only way I can get the bike to start is if I boost it. Any idea why it might be doing this? Other then the battery just being shot and I need a new one?

2nd.
I see that you all say the fan comes on around 220 (im guessing this is Fahrenheit because mine comes on around 105) but today it went up to 120 and the coolant light came on. The fan was still running but it didn’t seem to cool it down so Should I just change the coolant to fix this or could it be a bigger problem?

Thanks
 

·
Registered
Joined
·
6,980 Posts
If its not the battery then its the regulator/rectifier or the stator.

I would change the coolant just because you don't know if its ever been changed. It could help. but how hot was it when it went up that high?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
skibum91 said:
If its not the battery then its the regulator/rectifier or the stator.
Is there any way i can check to find out what it could be? or is that something that you'd have to take it in to get it looked at?


skibum91 said:
I would change the coolant just because you don't know if its ever been changed. It could help. but how hot was it when it went up that high?
It was runnin at like 100-110 area back and forth..then next thing i know i looked and it was at 120 with the light flashing
 

·
Registered
Joined
·
6,980 Posts
Yes, if you get the service manual, it'll give you specs and what to check for.

I mean outside temp.
 

·
Registered
Joined
·
6,980 Posts
search the site here, I know people have them online you can download.

how long had you been riding? was the bike still warming up?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #7 ·
Alright i'll take a look for one on here.

I just started riding, so i wasnt really doing much on it. And yea it was warmed up, was going for like 35 min before the temp went up that high.
The night i picked the bike up my friend drove it home for me and it happend to him too, the bike was running fine for like almost 2 hrs then the samething happend, but we went and had a coffee and when we started it back up it was fine and hasnt happend since till today.
 

·
Registered
Joined
·
6,980 Posts
i'd check the coolant see what it looks like. You might also want to test the thermostat. that could be the problem.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
Ok dont know if this helps get me any closer to a answer.....the lights come on VERY low though, u can hardly see them, and when u try to start it they turn right off.

I hooked it up for a boost and they all lite up nice and bright, but it wouldnt turn over...it was givin me one of them FI errors.
 

·
Registered
Joined
·
2,244 Posts
You probalby have a bad battery. With all the boost starting you have done, it is probalby a good idea to change it even if it is not the main problem, so I would start there, then you will need to do a charging system test. I think I have a link up top stickied for charging tests, but if not I need to put it up there.... so remind me if it is not up there.

Check my Yahoo IM ID, and if you see me on hit me up for a manual.

As far as the temp, are you sitting still idling alot, or is this happeneing going down the road? if you are sitting in very heavy traffic it is not uncommon for the temp to get to a point that the fan cannot handle. Best bet when this happens is to go for a ride at highway speeds IMMEDIATELY to cool it down, if it it doesnt drop shut the bike down. Shutting the bike down will actually cause the temp to rise more for a short period of time, so try not to do that unless you HAVE to.
 

·
Registered
Joined
·
1,178 Posts
hey man, i got the same bike, i picked one up 3 weeks ago. the highest i seen my temp gauge was today in the city, it was at 104, then the fan kicked in and it went down to 99. if i were you i would change to coolant ( wouldnt hurt to change it )
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #12 · (Edited)
Motojoe_23 said:
I think I have a link up top stickied for charging tests, but if not I need to put it up there.... so remind me if it is not up there.
I dont think you have it up there but i think i found the link u were talkin about.

I also sent you a msg on yahoo to get that manual from ya, dont know if you got it or not.

As for the temp, it was from idling..i just got the bike so im slowly learning how to drive it so its been mostly slow speed stuff im tryin now so theres lots of idling goin on. I will get the shop to change the coolant when i take it in for inspection and all that crap which will be soon.

Now if i could only get the other problem fixed so i could ride the damn thing! haha

PS.. this might sound stupid, but how many fans are on the bike...is it just the 1? and if so would it be worth it to put another one on the other side?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #16 ·
i got it started!
we used a different car and it started right away...we checked the voltage with a meter and the volt. was at 11 before...its up over 13 now so im lettin it sit for alittle then gunna try to see it if will start up again.

It also cleared up the error that i was gettin so it had to be due to lack of power
 

·
Registered
Joined
·
2,244 Posts
You need to remove the battery and give it a full charge for a couple hours at 1.5 to 2 amps. dont keep jumping it off, or risk killing that battery.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #18 ·
well i think i might just buy a new battery, im not sure yet cause i dont have a charger and since i havent learned to ride the bike yet i cant go for a ride to let it charge.

But thats a load of my mind to figure out its nothin major...least looks that its not
 

·
Registered
Joined
·
14 Posts
110 is high. My k1 runs at ~74 on the move and climbs to ~90 when static in traffic. The manual says to turn off the machine if it gets to 120.

Check your manual, of if you don't have one ring a Suzi dealer.

I would start by flushing the sytstem and replacing the coolant.
 

·
Registered
Joined
·
2,244 Posts
bornagainbiker said:
110 is high. My k1 runs at ~74 on the move and climbs to ~90 when static in traffic. The manual says to turn off the machine if it gets to 120.

Check your manual, of if you don't have one ring a Suzi dealer.

I would start by flushing the sytstem and replacing the coolant.
You must be talking Celsius. I dont even move my bike until it is about 90-100 degres farenheit. Fan come son at 224
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top