Suzuki GSXR Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter · #1 ·
It's goin down. All the parts are on the way. Got 03 1000 motor, harness, airbox, exhaust, gauges, motor mounts. Hell I even got the 1k forks comin too. Need minor odds and ends but will start very soon.. Will def post pics.
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #3 ·
Just got back from beach to see a bunch of goodies waitin for me. Will start tearin it up this week fo sho! Still need oil cooler and would like a 1k radiator but may have to temporarily modify mine to work for now. I got the gauges, controls, I think just about everything but if anyone can think of anything I still need thats out of the ordinary let me know. I also got some slick mounts that require no grinding of the frame.
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #5 · (Edited)
Here's the new motor and here's the old one comin out. I ripped the whole subframe and shit off mine cuz it was missin a tab plus it helped out with all the wiring. It took about 2 hours to get everything out and organized. I took my time with all the electrical and pulled the battery and whole harness out before attempting to pull the motor. then you disconnect the lower radiator hose and drain the fluid. If you keep the radiator attached then you dont have to drain fluid but you run serious risk of damaging the radiator. Plus I'll be reusing mine so I took it out first. You leave the oil in for nowor drain it doesn't matter.
Then there's 5 motor mounts. I had the bike on the rearstand then used a motorcycle jack to take the weight of the motor as I eased it out.
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #6 · (Edited)
As you can see I have a broken leg and just had surgery not long ago and have to have another one. With a jack and stand it can be done easily. You can see my homies ain't nowhere to be found lol. Main thing to realize is that most everything is made of aluminum and will break easily. Be careful breakin bolts loose cuz stripped or broken ones turn small probs into big ones.
 

·
Registered
Joined
·
375 Posts
I'd be interested to see a pricelist when it's all done also. Will you be changing anything else, like swingarm and /or rear rim? Good luck, I know when I went from my 600 to my 1k, I knew that was what I had been searching for my whole life and could die happy.
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #10 ·
I'd be interested to see a pricelist when it's all done also. Will you be changing anything else, like swingarm and /or rear rim? Good luck, I know when I went from my 600 to my 1k, I knew that was what I had been searching for my whole life and could die happy.
I got a set of 1k forks with race internals but still need trees and clipons. I'm goin for a 10in stretch on the swingarm but I'm focused on the motor right now. I'm slowly gathering suspension components now. On money, I'm sittin at just under $2000 on the whole kit. That includes power commander, yoshi headers, controls, ecu, harness, airbox, throttle bodies, and everything else. You will get beat to death on oddball shit. I'll sell all my stuff later and give you the breakdown.
 

·
Registered
Joined
·
2,810 Posts
Good good... and whats been up with you bro... :shifty :arsenalwhat the hell did ya do to that lag???

:shiftySo what ya doin with all the 600 goodies?? sellin? I still need some exhaust:D
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #14 · (Edited)
Sorry, but those slick mounts I thought I had didn't work! I called hybridracing and I must say I am very pleased. They fabbed them up (out of stock) and rushed them to me across the country within days.
Very impressed with the quality. Def recommend them to anyone interested. $120 shipped. They have to be precise especially if ya wanna get away with as little grinding as possible. I messed with the other mounts for hours tryin to make it fit somehow but just ended up tired and pissed off. Hybrids mounts took about 2 minutes to install. I did a lil grindin on the spacer on the right side and that was that.
I'm retarded and can't upload multiple pics for shit or I would show more pics. Fortunetly, I'm a lil more skilled at bikes than computers. I put the mounts on and jacked the motor up til the mounts hit then took and traced them with sharpie. The whole time I'm using the bottom back mount as a hinge.
I dropped it down and wrapped it in plastic and got to grindin. Second try everything fit like a glove so I secured the other mounts.
 

Attachments

·
Registered
Joined
·
327 Posts
Discussion Starter · #15 · (Edited)
And there it is all stuffed. The motor itself is not really wider you just need to make room for the new mounts. It's suprisingly pretty comfy in there. I started wiring the thing up and workin on the fi system. I've been told that the 600 fuel pump will work and I've been told it won't. Any confirmation would be helpful but I'll find out soon enough newayz. I gave up for today. I also still need to get oil and coolant. Hopefully, I'll get it finished up this weekend.
 

Attachments

·
Registered
Joined
·
327 Posts
Discussion Starter · #17 ·
I know I'm just missing something stupid but it's late and I'm tired. I turn the ignition on and it says check. I jump it into dealer mode and it still says check. No codes:hmmm:. Has anyone else ever had this problem? I'll start checking every sensor tomorrow. I just hope there is nothin wrong with the ecu or anything. The harness has been chopped and spliced a little but wiring is my specialty. It just may take a lil longer to figure out.
 

·
Registered
Joined
·
7 Posts
new igintion

I know I'm just missing something stupid but it's late and I'm tired. I turn the ignition on and it says check. I jump it into dealer mode and it still says check. No codes:hmmm:. Has anyone else ever had this problem? I'll start checking every sensor tomorrow. I just hope there is nothin wrong with the ecu or anything. The harness has been chopped and spliced a little but wiring is my specialty. It just may take a lil longer to figure out.
your gonna need an new igition switched or wire a diode into the line thats what im having to do to mine also that thing that looks like an amp needs to be replaced with the same year model motor u got r no sparky gonna happen
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top