Suzuki GSXR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 05 600 gsxr it had an 2000/2003 engine on it with wiring, i order an 05 600 engine I installed with the old harness it cranks it has spark but doesn't start just backfire and ruff start when i give gas. Is it posibel to make it work wit the 00/03 wiring and cdi?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
315 Posts
This is just a wild guess and hopefully someone else here knows more. The timing chain sprocket is very different between the two engines. Part of it is associated with the cam position sensor and ignition timing. You might have to get a K5 ECM or, if you're lucky, install the K3 sprocket on your K5 engine. Don't blame me if you swap sprockets and it blows up.

P.S. I'm guessing that the K5 ECM uses different connectors than K3. If so, you're really going to need to swap harnesses too in order to swap ECMs.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hahahahah billv thanks for the info i just order the k5 wiring and cdi i just will wait on them to test I don't wanna blow my new engine


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
32 Posts
This is just a wild guess and hopefully someone else here knows more. The timing chain sprocket is very different between the two engines. Part of it is associated with the cam position sensor and ignition timing. You might have to get a K5 ECM or, if you're lucky, install the K3 sprocket on your K5 engine. Don't blame me if you swap sprockets and it blows up.

P.S. I'm guessing that the K5 ECM uses different connectors than K3. If so, you're really going to need to swap harnesses too in order to swap ECMs.
+1
 
1 - 5 of 5 Posts
Top