Suzuki GSXR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just installed a new hotbodies undertail for my 2004 gsxr 750. All lights work fine, but now when I use the blinkers, they blink on and off really really fast. Is this normal or is there something I need to do to fix this. Thanks for your help.
 

·
Registered
Joined
·
6,980 Posts
It is normal, when going to LED blinkers. You can install a resistor to slow the blinking down, but if you don't mind it being fast then don't worry about it, I left mine as is.
 

·
Anti-squid moderator
Joined
·
6,476 Posts
Bugman from gixxer.com has an awsome write up on his website on how to fix this. I did the fix and just used a different flasher relay from NAPA autopart and all fixed.
 

·
Registered
Joined
·
85 Posts
theres this thing at the top called the "search" button. J/K just search for bugman
 

·
Registered
Joined
·
935 Posts
I currently put some led blinkers in the back.... if I were to put some leds in front and put resistors on all four blinkers would it slow the flash back to normal? Has anybody done this?
 

·
Registered
Joined
·
1,517 Posts
dim_sum said:
I currently put some led blinkers in the back.... if I were to put some leds in front and put resistors on all four blinkers would it slow the flash back to normal? Has anybody done this?
yes it would, but you could leave it if you wanted to and it would not hurt anything
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top