Suzuki GSXR Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Automotive tire Hood Automotive lighting Motor vehicle Trunk

Tire Automotive tire Motor vehicle Automotive design Sports equipment

Dvi cable Electrical wiring Cable Auto part Wire
I cannot figure out what this connects to for the life of me. The bike was starting fine I put new fairings on removed the gas pump put it back in didn't start I took it off noticed this part was unattached to anything. Does anyone know. GSXR750 2006. I am new to bikes and working on them. Much appreciated.
 

·
Registered
Joined
·
105 Posts
I'm guessing the fuel tank was also removed. Check out the diagram and schematic I have linked below. In a diagram for the "EVAPO SYSTEM E33). It looks like Part #1 (tank breather valve hose) by its shape and what appears to be the breather valve attached on the one end. If it is, look for an open-ended metal tube on the underside of the fuel tank for it to attach to. With the molded hose already attached like it is, when the fuel tank is in place, the hose should be naturally lying right next to its intended attachment point at the metal tube on the tank.
2006 Suzuki GSXR750 OEM Parts | MotoSport
 

·
Administrator
Joined
·
11,219 Posts
^I think airhead has it. California bike? I have no such hose on my K6 750.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
So that tube doesn't actually connect to anything it is just a breather hose. Which leads me to my next problem. Why is the engine not starting when I connect the tank. It shows the rpm go up then go down makes the primer go off and the battery is fully charged however it doesn't start.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
To be honest I'm not sure. However I don't know anything I could do to the fuel pump differently. Ive already researched what to look for and clean. I inspected it and it looked absolutely fine. Also it only fits in one way. I hear a hum sound the rpm went all the way up and back down. Then a sound that I would assume was the primer. I had to put a new gas cap on. The old one had stripped bolts and the frame was somewhat bent. Is it possible that because it isn't perfectly sealed that's the reason?
 

·
Registered
Joined
·
5,092 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #16 ·
Okay just wanna say thank you to the GSXR community you guys were awesome. I figured out what the problem was. I knew it had to be something tiny. It happened to be the safety feature on my kickstand. I put a new pin on it and it was stopping my bike from starting. I tweaked it a bit and now the bike is better than ever. You guys were awesome thank you for helping a stranger!
 
1 - 16 of 16 Posts
Top