Suzuki GSXR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi all,

I have an issue with my bike cutting out, refusing to start but does turn over. Either way, i bought a second ECM to eliminate that as an issue. However, although the listing i bought the ECM of said it was for a K1-K3 GSXR 750, the part numbers are different. below are the numbers on the ECM's.

Currently fitted;
32920-35F00
112100-0530
12V NEP041

Purchased ECM;
32920-39F00
112100-0610
12V NEP047

Are there any major differences between the two that would require modifications/ could cause damage, or can it just be plugged in?

I remember with my old bike there were more than 5 ECU's that could be fitted, which all had different restrictions/ ignition timings etc, hence why i'm asking

Many Thanks
Ross
 

·
Registered
Joined
·
548 Posts
The 2000 is a 750y the 01 k1 750. The stva is slitely diffrent and the y and k1 fuel pump are a little diffrent. Ones a 3 wire 1s a 4wire I beleive something to do with the fuel level. As far as the ecm it will run your bike just fine with no problem .i had a issue with my 750y and trouble shooting I wound up with 3 computers I had the 2 computers you have and the 04-05 they all ran my bike the same.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
very strange then. I plugged the new ECM into the bike and it straight away caused a misfire. I'm wondering if that is that the ECM isn't compatible, or pointing to my issue/ fault. I had it in dealer mode and no error codes came up?
 

·
Registered
Joined
·
20 Posts
The 39F00 is for a 600. Although a 750 may start and even run with it, it will not work properly and will cause damage in the long term. You need a 35F00 ecu.
Always replace your ecu with the same part number (check the label)...
 
1 - 6 of 6 Posts
Top