Suzuki GSXR Forum banner
1 - 4 of 4 Posts

·
Registered
2007 gsxr750
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi,everyone I was checking my yesterday evening and I was looking at my ecu,the previous owner disconnect the pin 30,black wire with brown stripe,to stop f1 code coming up,anyway I noticed another pin was pulled,I think its pin 21,the wire is brown with a yellow stripe,I think,anyway the wire is just sitting there,does anyone know what pin 21 is and why is it disconnected
Cheers
 

·
Super Moderator
Joined
·
10,110 Posts
I pinned out my K6 750 using the wiring diagram but it is the US model.

On the Euro bike it looks like the Br/Y wire goes to the cluster. In the service manual it is labeled as the ignition switch signal. I'm wondering if it is to turn on the immobilizer light? We don't have the immobilizer system in the states so that is just a guess.

Since you are there, you might want to pull the connector and check for corrosion. The open pin hole can allow moisture into the connector and cause severe damage (pins corroded off). A dab of RTV over the open hole will fix this.
 
  • Like
Reactions: Todd_Sails

·
Registered
Joined
·
695 Posts
It is indeed for the immobilizer indicator light in the cluster. Immobilizer models use a different main harness where the Br/Y is present. They also use a cluster that has the light. But the front harness is the same for all models so the Br/Y sits unused on non-immobilizer models.

That connector has been a source of many problems. They used a shroud over it but it wasn't that good. Finally around 2009 they switched to a sealed connector and the problems went away. Long overdue.
 
1 - 4 of 4 Posts
Top