Suzuki GSXR Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
i HAVE A 2006 600 WITH ABOUT 18000. i HAVE A RATTLE IN MY VALVES AT BETWEEN 6200 AND 6800 RPM. ITS DONE IT SINCE I CAN REMEMBER ATLEAST 5000 MILES. HAD THE VALVES CHECKED BY DEALER SAID ITS FINE. I RUN AMSOIL FULL SYTHETIC OIL. BIKE RUNS FINE JUST THE NOISE IS A NUSIANCE AND IT DOESNT SOUND GOOD. WOUNDERING IF AYONE ELSE HAS THE SAME PROBLEM AND OR A SOULTION TO THE PROBLEM.
 

·
Premium Member
Joined
·
3,738 Posts
Make sure that you have the grommet located under the tank that itis secure. If it is not then you will get that rattle or type of sound when the bike reaches that RPM.
 

·
Registered
Joined
·
25 Posts
Do you have an aftermarket windscreen? My 07 600 had a terrible sound at that RMP and it ended up just being the Hotbodies windscreen. Sounded bad though.
Hope its that simple. Good luck
 

·
Registered
Joined
·
1,832 Posts
Do you have an aftermarket windscreen? My 07 600 had a terrible sound at that RMP and it ended up just being the Hotbodies windscreen. Sounded bad though.
Hope its that simple. Good luck
It's not that! I've ridden the bike, it's something in the motor because you hear it through the exhaust! I'm thinking you might just need your valves shimmed or something greg!
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
It's not that! I've ridden the bike, it's something in the motor because you hear it through the exhaust! I'm thinking you might just need your valves shimmed or something greg!
I took it to Suzuki City in Biloxi and they said the valves were good when I did the 15000 mile check I still got another year on the waranty so i need to work on blowing it up so I can get a new engine. :arsenal
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top