Suzuki GSXR Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Light Comes On, So I Shut It Off And It Goes Away. Weeks Later The Same Thing. And Now Twice Today
 

·
Registered
Joined
·
8 Posts
I have the same exact bike, and just started having the exact same problem. It came on one morning last week when I started it, so I shut the bike down. Started it again, and it was gone. Rode it several times with no problems. Yesterday, I started it up, no FI. Then I stalled it(yeah, duh), and when I started it again, the FI was back, along with the red light. I shut it down, waited a minute, started it back up. FI was still there with the red light. An hour later I started it, everything was fine.

My owners manual(pg 3-16) says this is a fuel injection failure, and that the bike should be taken to an authorized repair shop. It also indicates that it's alright to let it run. What is the problem with my fuel injection, and why doesn't performance seem affected?
 

·
Registered
Joined
·
112 Posts
Remove the set valve and cut the #5 wire and it will never come on again. If thats a bit to radical, when it acts up turn the bike fully off and reach down and fully open and close the valve a couple of times. Then restart as normal.
 

·
Registered
Joined
·
8 Posts
After doing some research on this site, I'm a little less worried. Seems like the set valve is a constant source of trouble on these bikes. I'll see how often this happens, maybe I'll remove the set vavle, and that wire.
 

·
Registered
Joined
·
8 Posts
Its not fuel injection, its Fault Indicator.

OP: pull the code
According to my manual, FI refers specifically to a fuel injection problem. That being said, wouldn't the red light be the Fault Indicator, and the FI stand for Fuel Injection since it's the only thing that causes that code?

Then again, does it really matter?
 

·
Registered
Joined
·
71 Posts
coincidently i had the same error code come up on my 600 today. shut it off and came back and it was gone. Im going to grab some fuel injector cleaner and put it in the tank, but beyond that i'll just leave it alone. my bike only has 1200 miles on it...if the fuel injectors are bad with only that many miles...im concerned.
 

·
Registered
Joined
·
190 Posts
Just something that i've noticed with my FI problem. When starting the bike up, keep it in neutral, put the stand up, twist key, then switch engine to start position. Allow that fuel pump to prime, and wait till all the noises are gone, THEN hit the start switch.

Seems that every time i've waited for all the values, pumps etc to prime in the beginning before starting i haven't got a FI error. Give it a shot, maybe it will work for you too.
 

·
Registered
Joined
·
9 Posts
had the same thing happen to me, i took my bike to the dealer and the tech told me when it happens turn off the bike, twist the throttle completely and let it go. then start the bike again and it will reset it, i havent had a problem since.
 

·
Registered
Joined
·
1,137 Posts
Ok people, I've gotten my set valve replaced under warranty once before and the problem still happened on occassion. I brought it back a few weeks ago and I believe Suzuki is now aware of this problem because the service guy told me that they had some problems with the cables for the set valve. It was either too long or too short, I can't remember. Either way they replaced the cable and everything is working fine free of charge of course.
 

·
Registered
Joined
·
2 Posts
Possible FI Indicator FIX

Found this on another board after months of searching and trying different things:shifty this one worked check out the link:thumbup:
It has detailed instructions with pictures so if you mess this up I am not responsible for anything that happens

DO NOT CUT OR PULL THE WRONG WIRE AS IT WILL CAUSE SERIOUS DAMAGE

Copy and paste this link in your browser and print out the details

http://jsdproducts.com/docs/2005-set.pdf

GOOD LUCK:thumbup:
 

·
Registered
Joined
·
129 Posts
If you don't let the fuel pump completely prime before you hit the start button it can cause the light to come on.

That would explain why when you shut it off and restarted the light went away.
 

·
Registered
Joined
·
246 Posts
I just got this error today on my 750. It says "CHEC" then "F1" and alternates between the two. The red light stays lit.

I have tried shutting everything down, turning the throttle max, then letting it go to its normal position, then turning the key, letting it prime completely, after no more noise is heard, I start it. Light and error is still there.

What do you mean use a paperclip to check the error code? ANy idea what's the problem?
 

·
Registered
Joined
·
2 Posts
Fix Works

Late last week I posted a fix, I had a chance to test it out on my bike, worked like a charm, performace was back to original, the light did not come back on. :thumbup:
 

·
Registered
Joined
·
126 Posts
my bike did this same thing a few weeks back.. i turned it off.. and restarted the bike.. no problem since till yesterday.. i riding down the road, and the engine shuts off, then back on.. then off and on.. pretty bad.. same error code.. how is the paper clip thing work?

My bike is a 2004 GSXR1000
 
1 - 20 of 22 Posts
Top