Suzuki GSXR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Hey everyone.. just noticed the other nite on the way home from Camp Pendleton that the lights on the bike after awhile started to "flicker", enough to where it was noticable on the ground ahead of me.

When they started flickering, if I tapped the starter, they came back on and stopped flickering for maybe 30 seconds or so. After about the 4th time of tapping the start button, they stopped flickering for about 30 miles or so, then did it again around the Costa Mesa area.

I checked all my connections on the battery and all, and everythings tight! Anyone have any ideas!?

--- Goobz!
 

·
Registered
Joined
·
311 Posts
Same problem on a 99

I have a 99 GSX-R750 with the exact same problem. I work second shift and ride my bike to work whenever possible so I ride alot at night. This has been a small problem ever since I have owned the bike. I have checked the connections and they appear to be good, cleaning them a little doesnt seem to help. Maybe someone out there has a fix to the problem but Im just comfirming its not your bike only.
 

·
Registered
Joined
·
6,980 Posts
sounds like you could have a loose wire arcing off of your frame somewhere, you need to go through the whole wire harness and see if there are any exposed wires. or it could be a loose connection somewhere, check every connector on the harness. make sure they are all clean too.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top