Suzuki GSXR Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
I have a 06 gsxr 600 abd the gear indicator is not working right..It keeps flicking between 2nd and 3rd when I shift up or down and says 2nd alot when Im in 1st as soon as i get 2 4th all is okay from there but as soon as i shift down to 3rd again it starts all over.....please help!!!
 

·
Registered
Joined
·
317 Posts
not that it's any help but i've got exactly same thing going on with my k7 600 so...
if anyone knows any tricks would be greatly appreciated.
 

·
Registered
Joined
·
2,060 Posts
Your best bet is to download the manual for your bike here in the site and it will point you in the right direction for removal. I believe you need to just wipe down the connections. But these sensors go out quite often and you may need a new one.
 

·
Registered
Joined
·
25 Posts
I worked at a suzuki dealrship and we tryd everything from cleaning the connections to checking the sensor on another bike, but it came down to they go bad on the bikes. If u bought the extended warranty the part and labor gets coverd by your dealer
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #6 ·
I got the manual but cant find it..anyone got a link or some pics that could help????
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #7 ·
I cant find it in the manual can anyone point me in the right direction so that I can clean the sensor..And how can i tell if its bad????
 

·
The Dude
Joined
·
4,386 Posts
Pull off the sprocket cover (left side) It is right behind it.
It is NOT the speed sensor that is on the front face of the cover. As I said, it is behind it.
 
G

·
Not trying to be a smart ass but what the hell you need it for hell only thing i get on my bike is N and thats all mine is older so i dont have all the nice lil lights but again what the hell you need that for listen to the bike and pay attention what more do ya need:headscrat
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #13 ·
I know what gear Im in when im riding but thats not the point..I want all my shit to work...I try and keep up on all my problems and correct them..I dont need it to work I want it to..but thanks for the reply anyway
 

·
The Dude
Joined
·
4,386 Posts
Thanks alot..Im gonna buy a new sensor and replace it
No problem. 10mm for the clutch cable arm bolt. There is a spring underneath it. Look at how it goes on before taking off! The cover bolts are 8mm. Now is a good time to clean all the gunk built up behind the cover too.

Let us know how you make out!
 

·
Registered
Joined
·
4 Posts
Hi there I have 2004 gsxr750 neutral light on the dash works fine.but when I attached a heltech gear indicator .the gear indicator shows 6 in neutral 5th in all the rest of the gears .do you think this would be a faulty gear positioning sensor....
 

·
Registered
Joined
·
783 Posts
Do you have a TRE installed? Unplug the GPS and measure the resistance between the P and B/W leads as you change gears. It should be something like 370,860,1500,2800,6100,17000 ohms for 1st to 6th (may vary with model). Clean the GPS if not. Otherwise it's probably the Healtech or, more likely, it's incorrectly set up.
 

·
Registered
Joined
·
4 Posts
Do you have a TRE installed? Unplug the GPS and measure the resistance between the P and B/W leads as you change gears. It should be something like 370,860,1500,2800,6100,17000 ohms for 1st to 6th (may vary with model). Clean the GPS if not. Otherwise it's probably the Healtech or, more likely, it's incorrectly set up.
What's a tre
 

·
Super Moderator
Joined
·
10,386 Posts
What's a tre
"Timing Retard Eliminator"

Suzuki neuters the bike a bit in lower gears by retarding the timing. The TRE plugs in between the GPS and the harness and fools the ECM into thinking it is in 5th gear so eliminating the retard function. It's a very popular modification.

Follow the wire from the GPS up to the main harness and see if there is one there. It is probably under the set.
 
1 - 20 of 23 Posts
Top