Suzuki GSXR Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter #1
Hi guys
I'm working on this gsxr that came in for a ecu mapping but at first, starting the bike has a bad bad idle, bike has been decat ,rear can a Yoshi and a bmc air filter
Here is the video
Any suggestions?
Thanks all for reading and helping

Sent from my Redmi Note 7 using Tapatalk
 

·
Premium Member
Joined
·
8,360 Posts
The engine is "hunting". The idle speed is low, the ECM commands the ICS to speed up, it over shoots and goes above the target speed, the ECM commands the ICS to slow down, it under shoots, repeat.

It could be tune, but a common cause is a sticky ICS (idle control servo) I would try some carb cleaner on the air side of the ICS first. I am assuming that there are no vacuum/intake leaks.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #3
Thanks, will look into it, apparently this happend once the exhaust line has been changed

Sent from my Redmi Note 7 using Tapatalk
 

·
Premium Member
Joined
·
8,360 Posts
Thanks, will look into it, apparently this happend once the exhaust line has been changed

Sent from my Redmi Note 7 using Tapatalk
Maybe flashing the tune will take care of it as I could accept that a lean mixture could cause it.

Let us know what happens.
 

·
Registered
Joined
·
159 Posts
I currently have the same bike with a M4 full system, no EXUP, PCV, and servo buddy. It has done that since day 1 on mine and has not stopped. A flash w/ tune from what I have heard should fix it. Suzuki recalled the ECU for the 1000R but not that standard and I was told by KWS that some of the ECUs on the stock ones have also been recalled but not all (not sure if this is true or not). Before I put the PCV on it the bike was absolutely awful even stock. after the PCV I was able to combine 3 maps after many rides and trying to log where the lean rpms were. Even without a dyno I was fairly successful but it still does it on start up until the engine is warm. I have a flashed ECU coming and will compare, but until then flash it and let us know what you find please.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #6
Thanks for all the info, I will have the ecu tomorrow in my hands and will see what is there and also how the ignition maps are, if they a restricted in lowers or not, will keep updating

Sent from my Redmi Note 7 using Tapatalk
 

·
Registered
Joined
·
309 Posts
Discussion Starter #7
About the recall I have talked to another owner of this bike and apparently it had to do with the shifter kill times (not sure if this info is correct)
Regarding the ecu,it will be tested tomorrow
Will update what the result is with the idle

Sent from my Redmi Note 7 using Tapatalk
 

·
Registered
Joined
·
159 Posts
Where I am at with my 17 GSXR 1000 (standard) and the ECU flashed/dynoed with Woolich by KWS.

The fuel curve is insanely smooth, the idle seems to bounce between 1000/1100ish and 1200 once you pull the clutch in and roll to a stop, the rpms hang a little when your slowing below 3k rpms or if your at idle and accidently just move the throttle it will increase 500/1000ish then slowly drop back to idle. No complaints at all though and KWS claims the idle is normal. The only thing I read via Brocks website is that the o2 sensor should still be removed even after the flash so I am not sure if my stock sensor is affecting the bike even with the flash. All I know is in the 2k miles (just purchased it with 0 miles recently (lots of these on the gulf coast that never sold)) I have on I have never been this happy to ride it. So with the flashed and mapped ecu I have the o2 sensor, pair valve, and PCV still installed but I cleared the fuel table on the PCV so its not doing anything for the bike at the moment.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #11
Hi guys
Quick update
I managed to get the idle stable, no bouncing table dancer anymore.
Did shi...t load of tests and the solution for me vas +11tps in idle and +15on iap idle, also the etv increase to 0.6 (initial is 0) anything above 0,6 will make it idle higher and higher rpm with same issue, hunting up to 5/600 rpm depending from time to time.

Sent from my Redmi Note 7 using Tapatalk
 

·
Registered
Joined
·
309 Posts
Discussion Starter #12
Maybe flashing the tune will take care of it as I could accept that a lean mixture could cause it.

Let us know what happens.
Yes,have done some tests,main reason is it leans out much

Sent from my Redmi Note 7 using Tapatalk
 

·
Premium Member
Joined
·
8,360 Posts
Did shi...t load of tests and the solution for me vas +11tps in idle and +15on iap idle, also the etv increase to 0.6 (initial is 0) anything above 0,6 will make it idle higher and higher rpm with same issue, hunting up to 5/600 rpm depending from time to time.
What language do you speak? :rolleyes:
 

·
Registered
Joined
·
309 Posts
Discussion Starter #14
What language do you speak? :rolleyes:
In the wrt
I the fuel tables increase by % (tps and the IAP values)
The etv factory is 0 and this value to 0.6 was the sweet spot for this one

Sent from my Redmi Note 7 using Tapatalk
 

·
Premium Member
Joined
·
8,360 Posts
In the wrt
I the fuel tables increase by % (tps and the IAP values)
The etv factory is 0 and this value to 0.6 was the sweet spot for this one

Sent from my Redmi Note 7 using Tapatalk
mntm
 

·
Premium Member
Joined
·
517 Posts
Hi guys
Quick update
I managed to get the idle stable, no bouncing table dancer anymore.
Did shi...t load of tests and the solution for me vas +11tps in idle and +15on iap idle, also the etv increase to 0.6 (initial is 0) anything above 0,6 will make it idle higher and higher rpm with same issue, hunting up to 5/600 rpm depending from time to time.

Sent from my Redmi Note 7 using Tapatalk
I have WRT with the Log Box installed, so I understand what you are saying with things like % increase of TPS and IAP values but I do not know what etv is.
 

·
Registered
Joined
·
159 Posts
293207

Same as the one you just did (this is mine). Went for a ride this weekend for the first time with the flashed/tunes ECU. Its amazing but the idle is still bouncing between 1000-1200rpm. Not an issue but just unusual to a degree. One this I found is even with the flash the o2 seemed to still affect the bike so I went out with the o2 sensor in and then went for a ride with the o2 sensor unplugged. No change for the idle or the hanging/hang dropping revs 2k and below but the fuel table was noticeably different (more power and less vibration with the o2 unplugged.

Here is something strange I noticed (unrelated), Some oil was on top of the rubber hose at the hose clap that attached from the water pump to the left side of the radiator. Not sure why and couldn't find any leak?. My front brake has become kind of snatchy/clicky when I squeeze the lever it makes a noticeable click/grab.
 
1 - 20 of 21 Posts
Top