Suzuki GSXR Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
i have a gsxr600v 1997 bike after getting it out to start getting it ready for this year the electrics are all dead apart for the neutral light. ive checked the fuses but thing it mite be the ecu box under the seat? has anyone had the same problem and can anyone help
 

·
Registered
Joined
·
2,244 Posts
What do you mean they are all dead?

Does the battery have voltage? Have you checked it?
If yes, does the fuel pump prime when you turn the key and kill switch to on?
If no, sounds like a switch problem
If yes, sounds more in depth, and we will need more info.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
my bike is dead

ive turned the key ive check the kill switch and the battery and even the side stand but she is still dead the bike did run for about 5mins before cutting out now every this is dead not even the light work? anything you need to know?
 

·
Registered
Joined
·
124 Posts
Put a digital multi meter on the battery and have someone else start the bike. While you're starting it, the battery will probably go to zero. It sounds like you have a "dead cell" on your battery. You did say that you checked it, right? Did it have full power?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
the battery is a new one so i know its not that.at the moment nothing works apart from the neutral light. and when you turn the key to the on position there is a click sound from around the battery and ecu area? :bowdown:
 

·
Registered
Joined
·
2,244 Posts
Just because it is new doesnt mean it isnt dead.
you need to put a meter on it, see if it has 12v
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
i hear what you are saying but on my bike when the battery went last lime it was a constant clicking sound under the seat. the bike did start up and did run for about 5mins or so. then all the light went out and the engine dyed. i turn it off then turned it back on but there was nothing? dose the ecu controll all the electrics or is it just for the engine? if you have a copy of a wiring diagrans for the GSXR600V that would be a great help in my hour of need. thank for your help :headscrat
 

·
Registered
Joined
·
2,244 Posts
HAVE YOU PUT A METER ON THE BATTERY!

I seriously doubt it it the ECM. Put a meter on the battery, and let me know what you get
 

·
Registered
Joined
·
249 Posts
check your wires, an exposed wire will do the same thing, make you think your battery has a dead cell. I pulled a bald spot until i found it .
 

·
Registered
Joined
·
6,980 Posts
Yea, if a wire is arcing off of your frame or subframe, or something else metal, then it could be causing that too, but first start with the battery, check the voltage.
 

·
Registered
Joined
·
124 Posts
Sweet. Makes you feel good when you finally find the problem and fix it, right? I always just try to find a starting point and work backwards until I find it. Now when it warms up, you can ride it. :cool:
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top