Suzuki GSXR Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
So I mentioned in my other post that my bike stutters around 4k and a tiny bit at 9k rpm. Would be nice if I could make this go away. I have another set of injectors I was going to try, as well as another fuel pump. But if anyone remembers at the beginning of the year I found one of the spark plugs was completely rounded out when I went to change them trying to fix a different issue woth low power in the high r's, turned out to just be a kinked fuel hose from the tank to the fuel rail when tank was closed and bolted down.

So I'm beginning to think this is the spark plug since both of my pump tested fine. Gets real bubbly a 4k and after a split second it has all of the power. And then at 9k on the highway I can feel some shuttering as well.

Should be noted I have removed the secondary butterflies from the throttle bodies since one of the plastic gears in the stva motor went. Did this to avoid any codes or limp mode. Wasn't sure if maybe that would cause this issues but am doubtful of it since people delete the stva. The bike does appear to be running a little on the rich side. It's my K2 750.

Any insight would be helpful, thanks guys.
 

·
Registered
Joined
·
503 Posts
I think you should test your tps with a ohms meter, it sounds a lot like you have a dead spot and it may not cause your fi light to come on.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #3
I think you should test your tps with a ohms meter, it sounds a lot like you have a dead spot and it may not cause your fi light to come on.
It is a possibility. Definitely will keep that in mind once I get this spark plug out and rule it out. Going to try a damaged nut remover hopefully within the next week
 
1 - 3 of 3 Posts
Top