Suzuki GSXR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
my bike won't start. the FI light keeps on coming on. i put it in dealer mode and it reads c41. i changed the fuel pump and the fuel pump relay and still nothing. i checked if the wires were on the ecu tight and that's no it. the only thing i have done was the tre mod and a radiator switch. i was reading a gsxr 1000 wiring diagram and i thought the fuel pump relay was the radiator relay(for some reason i do not know why). a black box was moving. so i think it's that. the black box that is connnected to your throtle bodies i believe. but what can it be and how can i check if it's that. oh by the way it's a gsxr 2000 750. i really need this fix asap. some one help thanks
 

·
Registered
Joined
·
2,244 Posts
There are several relays over there I believe. On the 2000 750 I think the ignition relay is over there (it comes on when the key and red kill switch are both turned on) to prime the fuel pump, and diagnose the FI system. I think the flasher relay is over there too. What does the code mean, have you looked it up? I dont feel like it right now, but if you do I will help you further
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #4 ·
yeah it means the fuel pump control system. a friend of mine came over and said just to wire the pump straight to the battery and see if it turns on. if it does it is more than likely a relay or fuse. should i do that if i do i know black and white is ground what is power? thanks.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
okay i hot wired the pump and it turned on. and used the fuel cut off switch to turn the bike off and it worked. so i need to know what is wrong i changed the relay by the battery is there another fuel pump relay or fuses i do not know about.
 

·
Registered
Joined
·
1,265 Posts
same problem, anything new?
 
1 - 7 of 7 Posts
Top