Suzuki GSXR Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Im thinking about buying the TRE from Ivan for my 04 1k and have a few questions. I will probably end up calling him too, but should I wait untill my bike is fully broken in? It only has 550 miles on it and Im doing the 600 mile service this saturday at my dealership. And will this mod affect the long term or reliability of the bike. Im also kind of clueless on where the TRE plugs in at. Tell me everything you guys no about this thing. Thanks in advance for any help.
 

·
Registered
Joined
·
543 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Thankyou for the links. I was wondering though. Will I have any problems with cold starts if I go with the Ivans one, instead of doing it myself with a resistor. I would rather go with an Ivans because its just a direct plug in. I dont want to do anything to the bike that requires some splicing or buying my own parts to make it work. Thanks
 

·
Registered
Joined
·
543 Posts
well they both have resistors, thats all a tre is, some people say they have problems w/ cold starts and some say they don't, hands down go with the switchable one, that way there is no dispute on cold starts.
 

·
Registered
Joined
·
5 Posts
tre

i have to say i just put ivans tre on my 04 1k. incredible difference. throw it on now. dont wait. only 550 miles. start riding ur bike the way ur gonna ride it. if u ride hard ride ur bike hard now so the computer will get used to it. dont babyt ur bike man. throughing the tre on now will break the tre in quicker as well.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 · (Edited)
Thanks... I have one in the mail from Speed Werkes. I just hope I can find where the damn thing plugs in at. Also did you notice any difference in the cold start ups with the ivans.
 

·
Registered
Joined
·
543 Posts
it plugs in left side under gas tank right above shifter...into the GPS plug....it's the only 3 wire harness down there. :thumbup:
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #8 ·
Is it the white harness with the black..pink..blue wires? You just unplug that and put one connection on each end of the Ivans TRE? Thanks. And also what rpm do you have your idle set?
 

·
Registered
Joined
·
2,244 Posts
Rane 1K said:
Thankyou for the links. I was wondering though. Will I have any problems with cold starts if I go with the Ivans one, instead of doing it myself with a resistor. I would rather go with an Ivans because its just a direct plug in. I dont want to do anything to the bike that requires some splicing or buying my own parts to make it work. Thanks
I have never had any trouble with cold starts. I always give a slight twist of the throttle though. always have. It is a habit from motocross days :cool:
 

·
Registered
Joined
·
2,244 Posts
funkmaster said:
i have to say i just put ivans tre on my 04 1k. incredible difference. throw it on now. dont wait. only 550 miles. start riding ur bike the way ur gonna ride it. if u ride hard ride ur bike hard now so the computer will get used to it. dont babyt ur bike man. throughing the tre on now will break the tre in quicker as well.

THE COMPUTER HAS NOTHING TO DO WITH THE HARD BREAK IN THEORY

I have no idea where this myth started but it is friggen hilarious :laughingr
The computer on a bike will adjust minimally compared to a car to adjust for air intake pressure and stuff like that. NOT to how you ride. It DOES detect your throttle position in reference to a shit load of other engine managment sensors and adjust the fuel and secondary throttle valves accordingly.... but it will do that from 0 to 1000000000 miles (if it makes it that long :lol: )

The hard break in is about seating your piston rings to the cyclinder walls before the cross hatch honing on the walls is worn off, which acts like a tiny little file on your rings and mates them perfectlyto the wall.
 

·
Registered
Joined
·
2,244 Posts
rkrummel01 said:
it plugs in left side under gas tank right above shifter...into the GPS plug....it's the only 3 wire harness down there. :thumbup:
No it is not, there is another similar one down there....

Is it the white harness with the black..pink..blue wires? You just unplug that and put one connection on each end of the Ivans TRE? Thanks. And also what rpm do you have your idle set?

this is correct. :thumbup:
 

·
Registered
Joined
·
543 Posts
Motojoe_23 said:
No it is not, there is another similar one down there....

Is it the white harness with the black..pink..blue wires? You just unplug that and put one connection on each end of the Ivans TRE? Thanks. And also what rpm do you have your idle set?

this is correct. :thumbup:
so what your saying is i'm wrong...NO, that is where it's at, i've plugged & unplugged a dozen of em, so if someone couldn't find it w/ my directions then they shouldnt even be trying to put it on. not being rude but wouldn't u agree?
 

·
Registered
Joined
·
2,244 Posts
Yes.... kindof. It is the only one with those color wires, but on some models (not sure if it is all of them) it is NOT the only connector that looks like that.
 

·
Registered
Joined
·
6,980 Posts
rkrummel01 said:
so what your saying is i'm wrong...NO, that is where it's at, i've plugged & unplugged a dozen of em, so if someone couldn't find it w/ my directions then they shouldnt even be trying to put it on. not being rude but wouldn't u agree?
Yea krum, he was saying there are 2 connectors down there that look exactly the same! Which he is right. You need to make sure its the right plug.
 
1 - 15 of 15 Posts
Top