Suzuki GSXR Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
Im having some problems with my bike, until now i didnt know existed. Im hoping someone here can help me out.

alright guys-heres my configuration:

2002 gsxr 1000
stock internals
nikko gpak (tre)
pc3
bmc race filter
velocity stacks
vortex gearing (-2, +2)
full system devil highmount exhaust

the basic problem is.........ITS SLOW AS DIRT!! The bike runs great, rides great, doesnt miss, sputter, have any weird noises/vibrations/misses, etc, but its just not fast-I got my butt handed to me by a stock (geared similarly to mine anyway-only mods) 2002 750!! The bike has always seemed quick, and I've never had any issues with it-there has been no abrubt change, and its only got 4k miles on it-WHY ARENT I FAST!! Besides the apparant lack of power, everything seems normal. The pc3 has the proper map in it, and its going to the dyno the beginning of the month for a tune-but i DOUBT I'm losing that much power-Its really dissapointing, someone help me out!!
:D :clap: :thumbup: :bounce :lol: :rofl: :bowdown:
 

·
Registered
Joined
·
3,280 Posts
welp, if its MAKING the power (which you'll know soon enough after the dyno)...then it HAS to be rider error somewhere....i mean its impossible to put down a good amount of whp and be slow.......unless yer 350lbs.+
 

·
Registered
Joined
·
4,768 Posts
usdm420 said:
welp, if its MAKING the power (which you'll know soon enough after the dyno)...then it HAS to be rider error somewhere....i mean its impossible to put down a good amount of whp and be slow.......unless yer 350lbs.+

I say rider error also.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #4 ·
nice of you guys to assume its rider error-fantastic. Let me clear that up-I KNOW ITS THE BIKE!!!

first-i got beat-then, i switched bikes-i then beat my own bike-then i let several people have a go at it-the 750 AND r1 (05 stock) beat it every time-and before you say launch-thats not it either-the races were roll on-around 50. The 1k pulled cleanly, but just didnt have the power.

SO-if all you can do is blame the rider, maybe youre not interested in helping me-although i would appreciate some non-bashing, "better than though" advice
 

·
Registered
Joined
·
139 Posts
I have the exact same set up on my bike. It might be in your gearing, change it back to stock. I have every thing you have excluding the sprockets, gearing. I ride/race a lot and the only thing i have trouble beating is the 05/06 gix 1k :2hard the busa, zx12 and every now again a zx10 if the rider has the balls. I weigh 225lbs so i think it is your gearing or maby pull the pike a part and look at your plugs, air filter, etc.etc.
 

·
Banned
Joined
·
641 Posts
your clutch could be slipping , your filter could be clogged, your map at top coould be too rich, you do have 2 down in the front and two up in the back right? and not vica verca? are you tucking your arms in at these high speed runs? The racers (ama moto gp) say that not tucking your arms at high speeds is the same wind resistance as losing 30 hp. You ram air ucts may be not connected properly, your injectors could be clogged. what speeds are they beeting you at? do they have hidden nos? they could be geared for the top speed run , yours is geared for dead start drag racing. My brothers r1 will pull on my 02 1k 4th,5th,6th gears but not 1st,2nd,3rd. The gixxers have a totally different gearing than the other bikes. The other bikes have to make up in gearing what suzuki has in power!! :thumbup: Just some ideas.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #10 ·
thanks

thanks for the suggestions-heres some more specifics:

filters new-not dirty at all, and oiled properly

plugs are recent, look good

the 750 is also geared, lower than mine-the r1 is stock-both beat my bike, riders switched to my bike, me to theirs, and then back-my bike lost every time

The motors got 2k miles on it-the injectors have closer to 25k on them-as well as the rest of the sensors-I think Im going to start by changing out the fuel injection rack, unplugging the g-pak, and pc3.

the clutch isnt slipping-i can drop it and pick the bike up in 5th gear

the bike is slow all around-no matter what speed we rolled on, It still lost

yes, i was tucked

I also invite anyone in the orlando/kissimee florida area (or nearby) to come by and look at/flog the piss out of my bike-Id like to get a baseline to compare-I can also offer a dyno pull to the person that brings a 2001-2002 gixxer1k with them-lol
 

·
Registered
Joined
·
442 Posts
i don't know if bikes do this or not, but could a sensor somewhere in the system be bad? and maybe the its causing the pc to run in a safe mode? i know its totally different, but when i have a sensor going bad in my integra the computer runs the car in a safe mode. i'm prolly way the fuck off here. i'm just trying to help
 

·
Premium Member
Joined
·
3,738 Posts
2002 gsxr 1000
stock internals
nikko gpak (tre) Get rid of this
pc3
bmc race filter
velocity stacks Which stacks you have
vortex gearing (-2, +2) Go back to 17 in front go one more up in rear or stay +2

full system devil highmount exhaust
 

·
Registered
Joined
·
1,621 Posts
Sounds like a fuel problem to me. You stated the injectors have 25k miles on them, why?? What do the plugs look like? (color, etc.) Injectors need to be cleaned periodically. Run some good injector cleaner through the system on your next two fill-ups, see if that makes any difference.

Also try reprogramming your PC3 again, you could have uploaded the wrong map by mistake. Has this problem always existed or is it a new occurance brought on by a new mod?

Like audi mentioned, are the stacks correctly installed?

Last of all, is there a possibility of bad gas?


JL
 

·
Registered
Joined
·
57 Posts
we will see but i am going to say if the tune in the power commander is a off the shelf map then could be the problem, we will see when you go to the dyno
 

·
Banned
Joined
·
641 Posts
I am wondering about the injectors with 25k on them. Were they bought on ebay or something some one might have accidentally sold you some 600 or 750 injectors.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top