Suzuki GSXR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys! Thanks for looking at this post! Hope you can help me. So I drive a k3 1000 with 68+ miles. I live in arizona so I drive in 105+ weather. Having said that. The bike will drive me to a from work which is maybe 8-10 miles no problem. But it's when I go to do a little lake trip or somewhere farther. The bike will shut down after making a backfire pop. The bike does not shut down electrically just the rpms die out and I roll. I know I did not switch the kill engine switch or turn my key. Mind you my bike is naked. I paid one of my techs at the shop I work at to "fix" the issue. He said he did clean the contacts in the kill switch and the connector in the frame on top of the head. Now the problem is back. Bike is acting like the kill switch is being pressed. Very weird i dont think it's my fuel pump I've pinned the bike and it pulls strong with no hiccups at all. I took the tank and removed air filter housing and took the cable out of the frame and took the kill engine switch off went thru it with a q-tip and cleaned the contacts and checked the wires for fraying and found nothing but the two wires from the kill engine switch were soldered to the corresponding orange wire to the connector. I re shrink wrapped the wires and I drive it to and from work but cant make longer trips. Any help would be awesome!
 

·
Registered
Joined
·
860 Posts
What temperature does it reach?
Yep, I was thinking the same thing. Sounds like its getting too hot and shutting down.

Does your radiator fan come on at anytime while riding, or sitting in traffic? Have you checked the coolant level?

That bike looks like it's had a pretty rough life before you got it. More than likely you will have some previously made bad decisions to work out of it...

The next place I would be checking would be the fuel pump. Could be giving up on you. My money is on temperature though.
 

·
Super Moderator
Joined
·
8,740 Posts
Welcome.

This does belong in the tech section.

I'm assuming there is no "FI" flashing in the temp window when it quits.

I'm also assuming that as you coast to a stop that "CHEC" does not pop up in the temp window. "CHEC" will show if the kill switch or a side stand relay problem are shutting the bike off.

There is no provision built into the bike to shut it off if it gets to hot. It just boils over and runs till it seizes. :devil I'm assuming you don't ride to that point.

From time to time there have been threads where the bike either stops and cranks but won't restart till it cools off or if it is shut off while hot, it will crank but not restart till it cools off. No codes shown.

The answer seems to be the crank position sensor failing when hot. I don't know why the post don't mention a CKP sensor error.

If you run out of options, you might try replacing it.
 
1 - 4 of 4 Posts
Top