Suzuki GSXR Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
hello i am new here. i have read about 300 pages of threads looking for something that might help me and have found a couple of things but i am still not able to get my bike running. I have a 1994 gsxr750 and for some reason it wont start. bike had been sitting for a while so i cleaned the carbs and still nothing, changed the spark plugs and nothing, was told it might be the coils so tried with my friends coils and nothing.
the bike will try to start it seems like its going to start but it never actually starts. i have checked for spark and i have no spark i was hoping someone could help me find what is wrong with it.
i am not the best mechanic out there but i know a little bit..
 

·
Registered
Joined
·
98 Posts
fuel pump?

did you check if the fuel pump is working?

Check if there is Gas, and Air, in 1994 when my motorcycle was brand new, it wont start because i have a towel blocking the air below the gas tank it goes from the tools compartiment and block the ait flow to the engine.
 

·
Registered
Joined
·
5,991 Posts
did you check if the fuel pump is working?

Check if there is Gas, and Air, in 1994 when my motorcycle was brand new, it wont start because i have a towel blocking the air below the gas tank it goes from the tools compartiment and block the ait flow to the engine.
its a carb issue bet $$$
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
or Gear switch, clutch switch? any one of these damaged or not releasing?
neutral light comes on when it is in neutral and if i try to start it the starter will spin but it does not start. if i try to start it while in gear ill pull in the clutch and the same thing starter spins but it does not start.
any other ideas on what it could be?
 

·
Registered
Joined
·
98 Posts
the thing is

neutral light comes on when it is in neutral and if i try to start it the starter will spin but it does not start. if i try to start it while in gear ill pull in the clutch and the same thing starter spins but it does not start.
any other ideas on what it could be?

you need Gas, Spark and Air to ignite, so you have gas, and air you dont have spark, then...

Why? because a switch? kik stand, cut off or clutch lever, where then Cable to the coil ?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
you need Gas, Spark and Air to ignite, so you have gas, and air you dont have spark, then...

Why? because a switch? kik stand, cut off or clutch lever, where then Cable to the coil ?
do you know where the cables for the coil come from?i can follow one all the way to something near the battery i dont know what its called but the other i do not know where it is going. It is a orange cable with a white stripe if that helps..
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
The Upper left and the wiring harness. just check everithing is connected.
i saw this one pink cable close to where the battery is that is not connected, but i cannot find what it connects to. but other than that one cable everything else is connected and still no start/spark.
 

·
Registered
Joined
·
12 Posts
electrical is so much fun

If you get yours figured out, you welcome to come help me with mine. If you do not have a repair manual, purchase one, or check it out from the library. It will give you at least a basic troubleshooting guide and technical specifications. The signal generator, mounted on the right side of the crankshaft, creates a small amount of voltage that feeds the CDI and collapses the curcuit sending the stored voltage of the capacitors to the spark plug coils and ultimately to the spark plugs through primary and secondary windings in the coils. If one of these components is not functioning properly the whole system is a no-go. Also, the CDI is fed with voltage through a curcuit that starts in the ignition, travels through the shut off switch, neutral relay, kickstand switch, and the tip over relay. If any component of this sytem is open, you will not produce spark. Check the manual and a wiring diagram.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 ·
i got it working already..not sure what i did but it is working now..i was about to give up and sell the bike so i decided to try to push start it since i hadnt done that..i was sure it wasnt going to work because i got no spark, so i rolled down a hill put it in second dropped the clutch and nothing..pushed it back up the hill when to try to hit the start button and everything died..took out the main fuse put it back in and it started up like nothing had ever been wrong with it..im not sure what was wrong with it or what happened but it starts everytime now on the first try..
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top