Suzuki GSXR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I have a 2007 GSXR 1000. Bike is completely stock.

My brother left it out in the rain for about 30 minutes or so. I tried to start it about 2 days later and it wouldn't start. I turned the key, i put it in RUN (then the injection kicked on) once I hit the starter a buzzing sound came from the side stand/signal relay. A few days later i tried it again and the fuel injection wouldn't even this time. I went through the motions of starting the bike and now the fuel injection wouldn't work. Its clearly an electrical issue. Does anyone have any suggestions about replacing any particular fuses or relays?

I replaced the side stand/signal relay but the bike still doesn't start.....any ideas...i need help.

Thanks for the support.
 

·
Registered
Joined
·
163 Posts
30 minutes in the rain should not affect it this is probably something stupid like the bike is in gear or didnt pull in the clutch, although it could be a fuse any thing is possible
 

·
Registered
Joined
·
552 Posts
Kinda sounds like a dead battery to me. And wtf is a side stand/signal relay? Are you talking about the kick stand sensor? Or the starter relay? And I doubt the rain is what caused this. I pressure wash my bike at the car wash all the time, runs fine. Most of the connectors in the harness have rubber seals in them.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top