Suzuki GSXR Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
please help. both hi and low beams not working. 2015 gsxr 600 with power comander. no problems with her till this.had her for 2yrs now. PC came with bike. ive never had both lights go at one time. i bought 2 new bulbs, upon looking at old ones neither looked burned out. put new ones in just in case. nothing no lights at all. already checked fuses and even switched them around. already checked battery off and running, 12 v off and 14ish running. checked hi / low switch on handlebar, no obvious/unusual damage. checked with volt meter and on dc or ac cant remember showed negative #s? jumped wire across switch wires and still nothing. open to suggestions. also no other electrical issues noted,dash works and blinkers, running lights all come on. horn works fine.
 

·
Premium Member
2005 GSX-R600 Anniversary Edition
Joined
·
2,783 Posts
DC volts. Check for power at the fuse. You probably have a bad connection between the main harness and front harness.
 

·
Super Moderator
Joined
·
10,290 Posts
Welcome.

I don't have a wiring diagram, but on a 2011 model the common components for both headlights are the ignition switch and the starter button (the lights go out when you press the starter button)

I would go to the starter switch first.
 

·
Registered
Joined
·
2 Posts
please help. both hi and low beams not working. 2015 gsxr 600 with power comander. no problems with her till this.had her for 2yrs now. PC came with bike. ive never had both lights go at one time. i bought 2 new bulbs, upon looking at old ones neither looked burned out. put new ones in just in case. nothing no lights at all. already checked fuses and even switched them around. already checked battery off and running, 12 v off and 14ish running. checked hi / low switch on handlebar, no obvious/unusual damage. checked with volt meter and on dc or ac cant remember showed negative #s? jumped wire across switch wires and still nothing. open to suggestions. also no other electrical issues noted,dash works and blinkers, running lights all come on. horn works fine.
 
1 - 5 of 5 Posts
Top