Suzuki GSXR Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
ok when i turn the key on my k4 600 nothing happens. no fuel pump noise, lights, or gauges.

i stopped to refuel and when i went to start it the gauges turned on for a second, but then after that nothing at all.

the battery connections are good, i also swapped the 30 fuse and the 15 ignition fuse.

i dont know where to check next
 

·
Banned
Joined
·
12,190 Posts
Maybe the ground to engine or frame?.Have you checked all your major harness connections,what about the wires to ignition and kill switch..?
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
do you happen to know where those main grounds are? im having trouble tracing the wire from the negative battery post.

also for the kill switch and ignition wires, am i following them from front to back or do i need to open up the right side hand control box.

thank you
 

·
Registered
Joined
·
67 Posts
Discussion Starter #5
the battery is good.

now the only thing that happens is when when i turn the key to the off position the tach needle goes all the way up, then back down.

any idea what that means?
 

·
Registered
Joined
·
4 Posts
This is that same exact issue that I am having right now on my 2002 1000. I have gone a little further, I checked the battery voltage and found that when the ignition key is off, my battery reads 12.8V. When I switch the key ON, the battery reads 00.7V. Definately something wrong here. When I switched the key ON the last time (when it died), none of the gauges worked, I heard the starter relay click, but nothing else (no fuel pump whine, no additional relay clicks) like I normally would hear. Now the bike isn't doing ANYTHING. I'm with "Sticker Dude"...HELP!
 

·
Registered
Joined
·
4 Posts
After further troubleshooting, I believed the started relay to be bad, tested it in accordance with the service manual using the battery in the bike to actuate the relay, and it seemed to be bad with the results I saw. However, this morning I conducted the same test on the starter relay using a car battery (12V potential, same as motorcycle), and the relay worked perfectly. It seems as though the battery in my bike reads a good 12.8V when there is no load applied to it, and when any load is applied, it shorts out. I have a spare battery at home (out of my 98 Triumph T595) in which I will test my theory this afternoon. I will let everyone know the results.
 

·
The Honey Badger
Joined
·
11,975 Posts
try replacing the battery or atleast charging, if you ran it dead it coulda quit altogether
Get the batteries load tested. But I agree with Ry..both of you guys need to replace the battery. The battery can have 12V in it unloaded, but your bikes arent drawing that much current to drop that much voltage just by turning the key on.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #9
ok i put my voltmeter on the battery again.

reads 13.xx when key is off

reads less than 1 when key is on
 

·
The Honey Badger
Joined
·
11,975 Posts
ok i put my voltmeter on the battery again.

reads 13.xx when key is off

reads less than 1 when key is on
You have a bad battery. Replace it.
 

·
Registered
Joined
·
4 Posts
Verified bad battery with spare battery last night. Gonna try one of the Lithium Iron batteries (LFX14A1-BS12). MSRP is $153, but it supposedly will last twice as long as a Lead Acid battery, it's environmentally friendly, and it weighs about 1/5 the weight. Another added bonus for the guys who need to store their bikes, you SHOULDN'T have to perform any maintenance on it for up to a year.
 

·
The Honey Badger
Joined
·
11,975 Posts
Verified bad battery with spare battery last night. Gonna try one of the Lithium Iron batteries (LFX14A1-BS12). MSRP is $153, but it supposedly will last twice as long as a Lead Acid battery, it's environmentally friendly, and it weighs about 1/5 the weight. Another added bonus for the guys who need to store their bikes, you SHOULDN'T have to perform any maintenance on it for up to a year.
Thanks for the update..I have debated on going with the Lithiums but I'm going to hold off until I need a battery.
 

·
Registered
Joined
·
4 Posts
Ordered the battery from Power-Tripp Performance in Birmingham, AL for a total of $149.95 incl. shipping. Wanted the larger case, but they don't carry them, they only carry the size 2 (smaller case). It's probably better though, gives me room to add the power commander later and have a little extra room to put it in the battery box rather than the trunk.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #14
thanks for the help.

I changed the battery and it fired right up.

But i have never seen that happen before, i mean i was just riding the bike and then when i went to start it the battery was so dead that it wouldnt even light up the gauges. how does that happen?
 

·
Banned
Joined
·
15 Posts
thanks for the help.

I changed the battery and it fired right up.

But i have never seen that happen before, i mean i was just riding the bike and then when i went to start it the battery was so dead that it wouldnt even light up the gauges. how does that happen?
Hey sticker dood I saw your post for rear seat for sale. I dont have enough posts so i couldn't message you on there about it, but i'm interested, from OC. Still got it?
 

·
Registered
Joined
·
15 Posts
the battery is good.

now the only thing that happens is when when i turn the key to the off position the tach needle goes all the way up, then back down.

any idea what that means?
Ive got the same issue now with my 02 1000, Change the front sprocket and tried to fire it up and got nothing..
Was is just the battery you changed and it worked fine??
 

·
Registered
Joined
·
1 Posts
I'm having same issue right now. When I turn my key to the ON position, nothing happens. I used a gsxr 750 1998 injector
 

·
SuperMod of the North
Joined
·
27,724 Posts
This thread is real old. Start yourself a thread in the tech section. Make sure you add lots of details on what it does or doesn’t do. The grease monkeys will fix you up.
 
1 - 18 of 18 Posts
Top