Suzuki GSXR Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
What’s going on guys I’m new to the Gsxr forum. I have an 06 1000 that I wrecked last year and rebuilt and still working out the kinks that being said right now I replace the throttle position sensor and my STVA is messed up I believe but whenever I crank the bike and I go to give it throttle it dies it bogs down and dies I took the air cleaner out air filter and cleaned it I have disassembled my throttlebody cleaned it put it back together injectors my fuel line is brand new fuel pumps brand new no trash in the tank I’m bout to pull my hair out and sit this thing on fire Can anyone please help me with what might be the issue because I’m to the point of setting it on fire and rolling down a hill
 

·
Administrator
Joined
·
11,963 Posts
Welcome to the forum.

You have a basket of issues it seems. Did you replace the TPS or the STPS? Why?

Why do you think the STVA is "messed up" and what does that mean?
 

·
Mod of the North
Joined
·
30,149 Posts
What was damaged in the crash & what have you worked on to fix it? Are you getting any codes?
 

·
Registered
Joined
·
5,490 Posts
That's a K6 1000? Poor thing. May it rest in peace after what all's been done to it.

LOL

Good luck.

If and when the intelligent people on here get a bit more information, they'll get it running.
Not sure where you're going to sit though LOL. It looks like something out of a Dr. Seuss book LOL.
 
1 - 7 of 7 Posts
Top