Suzuki GSXR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
I just got my new hid i got 3 ballast 2 for the highs and 1 for the low but the issue im having is that the low beam is not turning on with the hid... i dont know what the problem can be since i try all of the ballast on the low beam and it didnt work help anyone???
 

·
GSXR LIFE STYLE
Joined
·
735 Posts
I just got my new hid i got 3 ballast 2 for the highs and 1 for the low but the issue im having is that the low beam is not turning on with the hid... i dont know what the problem can be since i try all of the ballast on the low beam and it didnt work help anyone???
might have a bad bulb thats what it sounds like does the high beam work on them?
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #4 ·
i pulled the bulb out and put a diferent ballast and buld and nothing but once i put the low beam it work good i think ima just get a white xenon bulb and put it in there
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #6 ·
08 750 i check all the cables
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #8 ·
all the hid are plug and play so thats what i did i contacted the company that sold me the hids and they send me 2 kits with h11 bulb bud the low beam is h7 so maybe thats the issue im going to check as soon that the rain stop ;) thanx for the help
 

·
Registered
Joined
·
364 Posts
they say plug and play but they mean is connect the flat tabs into where the headlight plugs into. Then you have to connect the ballast tothe headlight wires in order for the ballast to get power. It sounds confusing but thats the problem I was having before I got mine to work. I used the positive and negative from the headlight. Feel free to ask questions.
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #10 ·
Bro I did all of that i got the high bean hid working but the low beam dont want too i give up ima just get a white xenon bulb and just leave the highs 8000k the balast that didnt want to work on the bike i just installed on my truck since one of the balast when bad on me lol thanx everyone that reply :thumbup:
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top