Suzuki GSXR Forum banner

21 - 40 of 69 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter #21
Even though the kickstand theory is a great idea of the possibile cause, I just do not think it could be it.

If I have my bike running and have it in gear and put down the kickstand, the bike's engine dies and you have to restart it.


During my problem, the engine does not die or lose power, it is still running.
I wish I had a GoPro to mount on my helmet to show you guys what it is doing.


In 30 minutes I am going to tear her top off and see if a spark plug is either mis gapped or bad.
 

·
Registered
Joined
·
63 Posts
Let us know when you figure it out. Getting the answers is only going to help me better understand my own bike in the future.
 

·
Registered
Joined
·
184 Posts
Discussion Starter #23
Two days before that I noticed the large air tube on the top-rear of the air box was not connected. I connected that and thought that is why it was dropping. So I went for a ride and it happened again, which leads me to the other day starting this thread and reading about the spark plugs...

I ended up checking all four spark plugs and they looked fine. I ensured the gap was correct and just placed them back in. I did notice that when I was removing the air box to get to the spark plugs, the large air tube that connects to the bottom/front-right of the air box was not connected.


I was waiting till the weather cooled off today before I headed out to see if I fixed the problem by just connecting that air hose.



Kick Stand: My kick stand needs replacing because it doesn't feel tight and need a new spring. I tested the kick stand shut off and it is working correctly. I put it up on a rear stand and put it in first gear. I put the kick stand down and the bike killed the engine.

I noticed that this is different from what I experienced.


I will try to go out for a ride shortly and see how it does. If not, I will try it out tomorrow.


Thank you to everyone that has tried to help.
 

·
Registered
Joined
·
1 Posts
Have you found the problem to your bike? I'm having the exact same issue with my 07 gsxr600.. any help would be appreciated. Thanks
 

·
Registered
Joined
·
184 Posts
Discussion Starter #25
Nope...
Is your red light on the dash? FI code? C28?

I am thinking it is because the previous owner removed the secondary butterflies because of the C28 error (STVA issue).

I thought it was the vacuum tubes because they were disconnected, nope. I thought it was because of a spark plug, nope. I thought I could fix the STVA, nope. I thought I could find some secondary butterflies and replace them on the Throttle Body, nope.

I have failed miserably at fixing this problem. If you fix yours, please post here.
 

·
Registered
Joined
·
6 Posts
I also have an 06 gsxr 750 and started experiencing the same problem today...Did you ever figure out what was going on with it?
 

·
Registered
Joined
·
184 Posts
Discussion Starter #27
Nope, still an issue. I am hoping someone knows what is causing this...

Have you done anything to the bike recently?
Anything out of the ordinary?
 

·
Registered
Joined
·
6 Posts
I haven't done anything. It just started about a hour ago. I have the same Jardine exhaust but I doubt that has anything to do with it. I'm going to try to go by the shop sometime this week.
 

·
Registered
Joined
·
184 Posts
Discussion Starter #29
Well maybe the exhaust has something to do with it then. Could be not enough back pressure (I have no idea).

So when you are riding and you are in any gear around 4K RPM, the RPMs will drop to 0 for a second or two and then come right back up?

This is what is happening to me.
 

·
Registered
Joined
·
5 Posts
I just started having the same problem today but my rpms drop to 0 in all the gears except 5th or 6th. i have a 2008 suzuki gsxr 750. im going to take to shop tomorrow and see what they can do with it. Have yall figured out anything new?
 

·
Administrator
Joined
·
5,189 Posts
Even though the kickstand theory is a great idea of the possibile cause, I just do not think it could be it.

If I have my bike running and have it in gear and put down the kickstand, the bike's engine dies and you have to restart it.


During my problem, the engine does not die or lose power, it is still running.
I wish I had a GoPro to mount on my helmet to show you guys what it is doing.


In 30 minutes I am going to tear her top off and see if a spark plug is either mis gapped or bad.
If I read this right the bike never looses power IE it does not die. Then it sounds to me like an indication problem, which could be a loose connection or a sending information problem. Have you checked all your connections?
 

·
Registered
Joined
·
5 Posts
well when im cruising going 50 the bike rpms will drop to zero, for about a second but during that second throttle wont respond to anythingbut after that or two it goes right back up to its original rpm or whatever the throttle is positoned at. but i wouldnt know what cables to check
 

·
Registered
Joined
·
184 Posts
Discussion Starter #37
well when im cruising going 50 the bike rpms will drop to zero, for about a second but during that second throttle wont respond to anythingbut after that or two it goes right back up to its original rpm or whatever the throttle is positoned at. but i wouldnt know what cables to check

Yep, this is the exact same issue. I might try to change the spark plug coils this weekend to see if maybe one is bad and causing it. I have checked the spark plugs and they are gapped correctly, new and look in great shape.

I am going to take a video of my next ride and focus on the rpms.
 

·
Registered
Joined
·
5 Posts
im picking up my go pro camera today. hopefully ill have enough time today to make a short video of it. im also taking by the shop today
 
21 - 40 of 69 Posts
Top