Suzuki GSXR Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Today I was riding behind a car which had its speedometer in the middle. His speedo was showing 55 km/h while mine was at 59 km/h. Considering that his speedo also shows a higher speed, my inaccuracy must be at least 5 km/h. I was wondering if there's something wrong with my speedo :shifty . Is anyone experiencing the same problem here? Could sb perhaps tell me his speed at a certain RPM in a certain gear (GSX-R 600 K8 only)? It would annoy me if I've been riding too slowly all this time due to a defective speedo. Thank you all for your time!!
 

·
Registered
Joined
·
463 Posts
did you gear the bike or anything.. thats usually what happens to the speedo when you gear the bike.. the sensor pick up is on the front sprocket for most.. so the speed of the sprocket determines the speed you are traveling, i.e if you gear the bike down, whick makes the front sprocket spin faster then it will read that your going faster than you really are... can be fixed with a speedohealer
 

·
Registered
Joined
·
201 Posts
nope nothing wrong with your bike.. they are all @8% high from the factory. you can buy a speedo healer etc to recalibrate it.
+2 on the speedo healer :thumbup: I have to get one myself, so I can slow down the millage on my bike.
 

·
Registered
Joined
·
1,371 Posts
Gee, I've never thought of that. You're right, over the years the ODO will show far more then the bike has actually been through :clap:
i was riding a few days ago and a speed trap thing read that im doing 47 and my speedo showed 44

dunno if thats a good thing tho
 

·
Registered
Joined
·
201 Posts
i was riding a few days ago and a speed trap thing read that im doing 47 and my speedo showed 44

dunno if thats a good thing tho
mine is way off, when I am going around 7x mph my speedometer tells me I am going 9x mph :shifty
 

·
Registered
Joined
·
61 Posts
Nope, nothing wrong with your speedo, all of them on sportbikes are off... My friend went out on his 1000 on a top speed run with a gps on windshield and at 186mph GPS only showed 175. For all the people that "max'd" their bike u hit 186 only once the rpm is max'd not the speedo. From what I hear it was something they started doing to prevent people from killing themselves:headshake
 

·
Registered
Joined
·
47 Posts
The healer goes by %? Correct? What would stock gears % be for a K8 750
Yep, the easiest way is just go get a GPS or have someone pace you. Do a few different speeds and average the percentages. If you failed 4th grade math, they have a calcualtor on their website.
 

·
Registered
Joined
·
85 Posts
Then I have a problem..

Ok I searched and found a few threads on speedo errors (this was the more recent). Most have suggested that it is a factory thing, set to show you're going faster then you are. Either for Safety or Ego.

Well mine is slow.

Got stopped by a Cop on the weekend, He said I was going 115 Km/h and my speedo said I was doing 100-105 Km/h. 10-15% error not sure I like that. And would have been better if it did show Faster, then he would have clocked me at like 90 Km/h and no points lost.

So is there any thing like a speedo healer for my '86 out there? Or do I need to replace my speedo?
Maybe I can find one with less mileage on it.
 

·
rotaredom
Joined
·
888,895,582 Posts
Ok I searched and found a few threads on speedo errors (this was the more recent). Most have suggested that it is a factory thing, set to show you're going faster then you are. Either for Safety or Ego.
dont know why they do that either, i figured it was so they can show a better fuel mileage then it actualy gets or ????? i put a speedo healer on my 06 1000 and have a +3 rear sprocket. the speedo is dead on, and my average is around 37mpg give or take. stock sprocket is around 41mpg with speedohealer, 44mpg without.
 

·
Registered
Joined
·
78 Posts
Gee, I've never thought of that. You're right, over the years the ODO will show far more then the bike has actually been through :clap:
i put a 51 tooth sprocket on my k8 600 and my ODO racks up miles almost twice as fast. for now my gauge pod is just disconnected.
 
1 - 16 of 16 Posts
Top