Suzuki GSXR Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
i have on 05 600 with just a k&n everything eles is stock no sprockets or anything. it was keep in my garage for a week due to the rain me had with half a tank of gas. i went and did a bunch of wheelies but when i did the bike seemed underpowered and kept back firing i also coulnt hold the bike as long as i usualy can and couldnt get as high. i was doing clutch ups by the way. it would keep backfiring as i would be ending my wheelies and when i shut it off and turnd it back on a loud back fire almost like a gun shot went off. im thinking it was bad gas. when i had it in the garage for a week there was haf a take of gas. i usualy get shell but i didnt this time and i filled my tank up at hess right bfore i went out. im thinking the gas had water in it causing pre det or something like that. im going to stick with shell only from now on but. but does anyone have any idea why it did this? im running 93btw its not wrong fuel abe just bad
 

·
Premium Member
Joined
·
9,267 Posts
Not necessarily bad gas - does your bike backfire under normal deceleration?

Backfiring happens when a temporarily overly-rich mixture condition ignites on deceleration, and the PAIR system, which injects air in to the manifold during deceleration for emission reduction, aggravates the problem.

Having some amount of unburned gas in the exhaust is normal on deceleration, but extreme power applications followed by abrupt decelerations (like racing, very aggressive riding, or pulling weelies) can often result in backfiring. It really doesn't hurt anything, but if it annoys you, you can do the PAIR mod.
 

·
Registered
Joined
·
6 Posts
I know this is a pretty new bike. How many miles are on it? Carbon build-up in an exhaust valve will cause this problem. Or ,quite frankly anything that causes a valve to not seat perfect can cause this. A leaky valve stem seal or worn valve guide will cause carbon to build up pretty quick.
 

·
Registered
Joined
·
10 Posts
what happened.. is when u put that k&n filter on, u leaned out the mixture, ure letting more air into the engine.. thats what the backfire is.. if its spitting out flames (no sound tho) then its way to rich..
all u gotta do is get a powercommander and richen out the mixture a little bit.. u'll be fine
 

·
Registered
Joined
·
6 Posts
I would suppose the question is, did the backfiring start when you added the K&N? Or, has it been running fine with the filter for some time, and just started backfiring recently?
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #6 ·
i would never back fire when i put the k&n on but yesterday it jus kept doing it this absolutly killed my wheelies. but it never did it before mabe once or twice but not lke it did yesterday
 

·
Registered
Joined
·
163 Posts
i have on 05 600 with just a k&n everything eles is stock no sprockets or anything. it was keep in my garage for a week due to the rain me had with half a tank of gas. i went and did a bunch of wheelies but when i did the bike seemed underpowered and kept back firing i also coulnt hold the bike as long as i usualy can and couldnt get as high. i was doing clutch ups by the way. it would keep backfiring as i would be ending my wheelies and when i shut it off and turnd it back on a loud back fire almost like a gun shot went off. im thinking it was bad gas. when i had it in the garage for a week there was haf a take of gas. i usualy get shell but i didnt this time and i filled my tank up at hess right bfore i went out. im thinking the gas had water in it causing pre det or something like that. im going to stick with shell only from now on but. but does anyone have any idea why it did this? im running 93btw its not wrong fuel abe just bad
if you only have a k&n your and no pipe your bike is probably running way lean
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #9 ·
my bike usualy runs fine though all last year i had it on i bought it when i bought the bike due toi needeed a new on and this is the first time its happened
 

·
Registered
Joined
·
6 Posts
In my est. even if your bike is running lean, you shouldn't be getting constant backfiring. A pop is one thing, but a exposion as load as a gun blast can point to only one thing, a valve not being closed when the cylinder fires. That can be from carbon build up, timing that is way off(this will also produce the sluggishness),or some machanical defect preventing good valve seal.
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #11 ·
my bike usualy runs awsome. my friends got an r6s with scorpion k&n and power comander its faster low end till like 1something then he starts to pull a little more te shot gun back fire only happened once when i started it. it was mostly poping when it was up in the air on one wheel
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top