Suzuki GSXR Forum banner

21 - 40 of 170 Posts

·
Registered
Joined
·
1 Posts
C28 stva

Alright so I have this exact problem on 06 gsxr-1000. When I flipped the ignition switch the flaps stay close and just sounds like its grinding and wants to go forwards .I tested the wires for the STVA motor and they seem fine. I also tried disconnecting the STVA sensor and it opens then closes the flaps but still grinds a little. I am going to check the wires on the sensor, maybe there's a short somewhere. I also read somewhere that on the K6 the flaps where suppose to close then open in the beginning, mines does the opposite.

With this does anybody have any suggestions I could try before I decide to try a used ECU or Throttle Body ?
 

·
Registered
Joined
·
2 Posts
I have a 2004 GSXR750 and I seem to be having the c28 code issue also, I could use the PDF file on the fix or The Geeks shipping address so I can send this damn part off to be fixed..... I have done some of the basics but after its resets and I go riding the F1 light comes back on and I get engine blah at about 8k RPM's and above unless I ease through the throttle. At any RPM above 8k if I snap the throttle it just craps out... Please help. I am done in Baton Rouge, Louisiana if anyone reads this that's close and can help. Thanks (( [email protected] ))
 

·
Registered
Joined
·
216 Posts
I have a 2004 GSXR750 and I seem to be having the c28 code issue also, I could use the PDF file on the fix or The Geeks shipping address so I can send this damn part off to be fixed..... I have done some of the basics but after its resets and I go riding the F1 light comes back on and I get engine blah at about 8k RPM's and above unless I ease through the throttle. At any RPM above 8k if I snap the throttle it just craps out... Please help. I am done in Baton Rouge, Louisiana if anyone reads this that's close and can help. Thanks (( [email protected] ))
Search ebay for stva repair. That is the only way he does business. I am definitely happy wiyh his service.
 

·
Registered
Joined
·
2 Posts
C28 code

Search ebay for stva repair. That is the only way he does business. I am definitely happy wiyh his service.

Thanks for the info, I created an account and purchased his service. Still waiting for him to send me an address to ship the part to. I would have tried this myself but with my luck, if it were raining hookers I would get hit in the face with a homo, so imma just let the geek do his thang... Thanks again for the help and I hope this fixes my bike
 

·
Registered
Joined
·
1 Posts
same problem

Hi,

I've got the same C28 fault. For some reason I can't download the wiring docs, can you email them to me please.

Thx!
 

·
Registered
Joined
·
2 Posts
Help Need Copy of Documents !

Hi got a GSXR750 K4 cannot download the pdf files can anyone send them through to me in word format or something easy to download, based in England, thanks great info so far on page.:0001136745-huh:
 

·
MPG mod
Joined
·
7,420 Posts
Actually, I've put together a website with the instructions instead of sending people the docs. I'm not a vendor here, so I can't post it here.
Unless you're selling something, a little help is fine.

NM checked for myself.


Sent from Motorcycle.com App
 

·
Registered
Joined
·
1 Posts
K7 750 - c28

Hi Guys,
I'm new to this site and am impressed with the wealth of knowledge for all things Gixxer. I bought a K7 750 a few months back as a track bike - 15k klms. As I got it off a mate I wasn't too worried about the FI light as I have done a few track days on the bike and it runs great. I thought I'd make the effort though and try and find out where the problem is - put it into dealer mode and of course the dreaded C28 was displayed. The STVA butterflies have been removed but I checked the STVA operation and it is working fine. As I said, bike runs great so certainly not in limp mode. The bike has a stock exhaust but the SET valve has been removed. Bike has a PC3. I know this topic has been discussed ad infinitum but I'm left scratching my head as what can be causing the C28 error considering everything seems to be operating fine - and why the C28 error is not causing the bike to run in limp mode? Any advice and suggestions of where to look next would be greatly appreciated from the very knowledgeable folk on this forum. Thanks.
 

·
Registered
Joined
·
2,034 Posts
Discussion Starter #39
If your bike is showing an error code, it is in limp mode. The fact it runs doesn't mean it's not.

Usually on the 06-07 bikes, the C28 code is caused by an ECU fault. There are cases where it is the STVA itself, by they're pretty rare. How did you check the STVA operation? Sometimes, it's possible for the sensor to be faulty and the error logic on the bike detect it as a problem with the actuator instead. Sensor issues are displayed as C29. When the sensors fail a certain way, the system just believes the secondaries are jammed up and throws C28 instead. Start by testing the secondary throttle position sensor resistance. You should be able to find two wires that read about 0.6 kOhms fully closed up to about 5kOhms fully open. You should also find two wires with a static value no matter what position. If that's good, your issue is most likely the ECU.

Do you have a friend with a 2006 or 2007 600 or 750? You can swap the ECUs briefly for a quick function test. No need to start the bike, just see if the error condition changes.
 

·
Registered
Joined
·
1 Posts
same probleme on my gsxr 1000 k10 c28

i realy need help guys on my gsxr 1000 k10, when i full gas it wont go over 11000rpm, and when desaccelere little bit it it make 13000rpm, on the dealer mode it show c28, i tested the STVA and i work good cause it allaways on the middle, this fault caused by a crash please i need help (sorry for the english)
 
21 - 40 of 170 Posts
Top