Suzuki GSXR Forum banner
121 - 140 of 177 Posts

·
Banned
Joined
·
307 Posts
Full open (or near it). That's what engages fast idle on prestart.
Which is odd because my bike doesn't fast idle even though my secondaries are open. I just saw a vid where the guy turned on the key and the secondaries close and then open back up. It makes me think there is something wrong with mine because mine barely move, and even though this is my first k7 600 it almost feels like I have to hit over 4000 rpms in 1st to even move
 

·
Premium Member
2005 GSX-R600 Anniversary Edition
Joined
·
3,649 Posts
Discussion Starter · #123 ·
Unplug the STVA main connector and turn them full open. Then go ride. If it's still "restricted" fueling is your problem. Should run like a raped ape with them fixed open. Have you ridden it in dealer mode? Getting any codes?
 

·
Banned
Joined
·
307 Posts
Unplug the STVA main connector and turn them full open. Then go ride. If it's still "restricted" fueling is your problem. Should run like a raped ape with them fixed open. Have you ridden it in dealer mode? Getting any codes?
Nope I haven't ran it but 3 miles because of the weather and wanting to be sure the engine is running right. I don't have a FI light but I will put it in dealermode today. I live in Evansville, and last I checked we have more white BS falling today. Will riding with the Stva main connector unplugged throw a code?
 

·
Premium Member
2005 GSX-R600 Anniversary Edition
Joined
·
3,649 Posts
Discussion Starter · #125 ·
Nope I haven't ran it but 3 miles because of the weather and wanting to be sure the engine is running right. I don't have a FI light but I will put it in dealermode today. I live in Evansville, and last I checked we have more white BS falling today. Will riding with the Stva main connector unplugged throw a code?
Yes, it will throw C28. But, if you cycle them open by hand after you unplug it, it won't restrict the bike.
 

·
Registered
Joined
·
3,322 Posts
Mr Chuckster, aka the Geek, I am having an issue with my 07 750. I now have the C28 & C29 codes.

I was just getting the C28 code at the track with the FI light as well. I was able to adjust the TPS and the light would go away. The bike would run normal. I would put the bike in dealer mode and that dash would be off. I would adjust it to dead center. Now the dash is dead center and the bike is throwing both C28 & C29 with the FI light as well. I have a track weekend coming up 7/2 & 7/3 and need this fixed ASAP. Any ideas????
 

·
Premium Member
2005 GSX-R600 Anniversary Edition
Joined
·
3,649 Posts
Discussion Starter · #130 ·
Sounds like you're confused and adjusted the STPS rather than the TPS. The STPS is mounted directly to the STVA. The TPS is mounted directly to the throttle body below the STVA. The dash adjustment is only for the TPS. When you adjusted the STPS by mistake, you threw it out of calibration and caused C29.

C28 on the 06/07 models are usually caused by a loose connection in the harness, a contaminated STPS, or a fault in the STVA itself. The only good news I can offer is that the STVA plug on the 06/07 faces up and makes testing the STVA directly pretty easy. Make sure you have two distinct 7 Ohms circuits.
 

·
Registered
Joined
·
3,322 Posts
When I put the bike in dealer mode, the dash (COO) was at the top. I adjusted that star shaped screw and aligned the dash dead center in the middle. The C28 code and FI light went away. The bike ran fine. The next track day the light and code C28 & C29 came on in the afternoon near the end of the day. The dash was in the middle but the bike was not running right.

I am pretty sure I adjusted the TPS sensor, I moved it slightly until the dash was dead center.

I will borrow a friends multi meter and test the STVA like you said.
 

·
Administrator
Joined
·
12,179 Posts
When I put the bike in dealer mode, the dash (COO) was at the top. I adjusted that star shaped screw and aligned the dash dead center in the middle.
Your in good hands, but what "star shaped screw" did you adjust? Pic of said screw?

The TPS is adjusted by loosening the two screws holding it and gently rotating the sensor housing.
 
  • Like
Reactions: Yellowgixxa

·
Administrator
Joined
·
12,179 Posts
Only one screw for the TPS on an 07. :wink
Fair cop :laugh

The way he phrased the sentence lead me to belive he might be adjusting something else. I was guessing the idle speed screw, but I guess we'll find out.
 

·
Premium Member
2005 GSX-R600 Anniversary Edition
Joined
·
3,649 Posts
Discussion Starter · #138 ·
Ok, then you're adjusting the right sensor for the "dash". I'll assume you're adjusting that with the bike fully warmed up and idling.....

For C28 and C29, adjusting that sensor is completely unrelated. Considering all the information you've provided, I think you probably just have a loose connection. With both C28 and C29 codes popping up, start with eliminating C29. Then if C28 still persists, check the wiring for the STVA. Usually the loose connection is at the ECU.
 

·
Registered
Joined
·
3,322 Posts
The multi meter I borrowed, the leads are too big too fit on the progs on the STVA. I will see if I can borrow a smaller one.

The throttle bodies are pretty much opening on start up and slowly closing. But it doesn't look consistent. If I leave the STVA unplugged and the throttle bodies fully open, what will be the result? Fast idle and burning allot of gas? I am sure this will make the bike run hotter. Don't want to do a track day in this condition. I have 2 days coming up next weekend.
 

·
Registered
Joined
·
3,322 Posts
Ok, then you're adjusting the right sensor for the "dash". I'll assume you're adjusting that with the bike fully warmed up and idling.....

For C28 and C29, adjusting that sensor is completely unrelated. Considering all the information you've provided, I think you probably just have a loose connection. With both C28 and C29 codes popping up, start with eliminating C29. Then if C28 still persists, check the wiring for the STVA. Usually the loose connection is at the ECU.
Ok I will look for a loose connection. I will check the ECU and everywhere there is a wire!!!

THANKS!!!!
 
121 - 140 of 177 Posts
Top